Video positioning is incorrect on youtube

RESOLVED DUPLICATE of bug 1511042

Status

()

defect
RESOLVED DUPLICATE of bug 1511042
6 months ago
6 months ago

People

(Reporter: coop, Unassigned)

Tracking

65 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

I'm using nightly on Win10 64-bit. Today while watching a video on Youtube, I noticed that the video was not centered properly in the viewing window.

I created a brand new profile and then took a screenshot to demonstrate the issue. Notice the black bars on the left and top in the attachment.

Interestingly, if I try to use Firefox Screenshots to capture the issue, the video is laid out correctly in the resulting screenshot:

https://screenshots.firefox.com/HVBfLg5D3krjXHDG/www.youtube.com

Version 	65.0a1
Build ID 	20181129095546
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
Reporter

Comment 1

6 months ago
Here's another screenshot of the same issue in theater mode.

Note: the black bars on the side are expected in this mode due to the aspect ratio of the video.
Reporter

Comment 2

6 months ago
Fullscreen mode seems unaffected.
Reporter

Updated

6 months ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Version: unspecified → 65 Branch
Reporter

Comment 3

6 months ago
I checked, and Youtube videos are displayed correctly on the same nightly version on OS X (Mojave).

Version 	65.0a1
Build ID 	20181129095546
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:65.0) Gecko/20100101 Firefox/65.0
The attached screenshot (attachment 9028682 [details]) looks like the same issue as shown in bug 1511146 on twitch, which means it's a dupe of bug 1511042.

(Presumably you're using webrender in the affected profile.)
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Component: Layout: Images, Video, and HTML Frames → Graphics: WebRender
Resolution: --- → DUPLICATE
Duplicate of bug: 1511042
You need to log in before you can comment on or make changes to this bug.