Closed Bug 1511075 Opened 9 months ago Closed 3 months ago

cannot reach "Clear Downloads" button in Library > Download with keyboard

Categories

(Firefox :: Downloads Panel, defect, P5)

x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox69 --- verified

People

(Reporter: MikkCZ, Assigned: danner.simon, Mentored)

Details

Attachments

(2 files)

Attached image screenshot
From one of sightless users of Firefox, we've got a feedback that the button "Clear Downloads" in Firefox Library is not accessible - does not have any accesskey assigned. It's the button in the top right corner on the attached screenshot.

How to find:
1) Open Firefox Library window. (e.g. Ctrl+Shift+H)
2) In the left navigation sidebar go to Downloads.
3) Check the top button "Clear Downloads" in the top right corner (toolbarbutton id "clearDownloadsButton", string "clearDownloadsButton.label" in browser/chrome/browser/downloads/downloads.dtd).
I agree, it is inaccessible if you use keyboard only. Cannot access this button with TAB key and no accesskey is assigned to this button.

Hi there, I think I have a working fix for this bug.

Can I please be assigned to it?

Chaitanya, yes, please take this bug if you have a fix.

Type: enhancement → defect

It appears this button is not in the tab order at all so completely inaccessible.

Component: Disability Access → Downloads Panel
Summary: "Clear Downloads" button in Library > Download has no accesskey → cannot reach "Clear Downloads" button in Library > Download with keyboard

It looks like the tabbable attribute is set only on Mac, likely by mistake because we do that on toolbarbuttons with type="menu", and this is not one of those. I'm not sure whether that'd be enough, but likely worth for someone to try and see.
The code is here:
https://searchfox.org/mozilla-central/rev/b9da45f63cb567244933c77b2c7e827a057d3f9b/browser/components/places/content/places.xul#343

Likely this has always been broken, unsetting version flags.

Mentor: mak77
Priority: -- → P5
Flags: needinfo?(mak77)

We assign the bugs when patches are attached, feel free to start working on it, and ask questions.

Flags: needinfo?(mak77)
Flags: needinfo?(mak77)
Assignee: nobody → danner.simon
Status: NEW → ASSIGNED
Flags: needinfo?(mak77)

Thank you for the patch! I triggered the landing.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/0ac292cba16c
Make Clear Downloads button always tabbable not only on OSX r=mak
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
QA Whiteboard: [good first verify]

I reproduced the issue on 65.0a1 on Linux (18.04LTS) and it's fixed on 69.0b13

(In reply to Negritas Sergiu from comment #12)

I reproduced the issue on 65.0a1 on Linux (18.04LTS) and it's fixed on 69.0b13

Hello Sergiu!
Can you please give more details?

(In reply to Cristian Comorasu, QA [:ccomorasu], Release Desktop QA from comment #13)

(In reply to Negritas Sergiu from comment #12)

I reproduced the issue on 65.0a1 on Linux (18.04LTS) and it's fixed on 69.0b13

Hello Sergiu!
Can you please give more details?

Following the STR from the description, I reproduced this issue using Fx 65.0a1(2018-11-29) on Ubuntu 18.04 LTS.
I can confirm this issue is fixed, I verified using Fx 69.0b13 on the same environment.

Awesome, thank you!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.