Closed Bug 1511210 Opened 10 months ago Closed 10 months ago

Intermittent TEST-UNEXPECTED-CRASH | mozilla/tests/wasm/f64_cmp.wast.js.html | expected OK

Categories

(Core :: JavaScript Engine, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jandem)

References

Details

(Keywords: intermittent-failure)

Attachments

(3 files)

Filed by: rmaries [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=214699963&repo=mozilla-central

https://queue.taskcluster.net/v1/task/et2wmr25SQyeakOaTR4GbA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-11-29T22:28:07.097Z] 22:28:07     INFO - TEST-START | /_mozilla/wasm/f64_cmp.wast.js.html
[task 2018-11-29T22:28:07.097Z] 22:28:07     INFO - Closing window 72
[task 2018-11-29T22:28:08.497Z] 22:28:08     INFO - TEST-UNEXPECTED-CRASH | /_mozilla/wasm/f64_cmp.wast.js.html | expected OK
[task 2018-11-29T22:28:08.497Z] 22:28:08     INFO - TEST-INFO took 1431ms
[task 2018-11-29T22:28:09.209Z] 22:28:09     INFO - Browser exited with return code 0
[task 2018-11-29T22:28:09.209Z] 22:28:09     INFO - Closing logging queue
[task 2018-11-29T22:28:09.209Z] 22:28:09     INFO - queue closed
[task 2018-11-29T22:28:09.217Z] 22:28:09     INFO - Setting up ssl
[task 2018-11-29T22:28:09.237Z] 22:28:09     INFO - certutil | 
[task 2018-11-29T22:28:09.258Z] 22:28:09     INFO - certutil | 
[task 2018-11-29T22:28:09.287Z] 22:28:09     INFO - certutil | 
[task 2018-11-29T22:28:09.288Z] 22:28:09     INFO - Certificate Nickname                                         Trust Attributes
[task 2018-11-29T22:28:09.288Z] 22:28:09     INFO -                                                              SSL,S/MIME,JAR/XPI
[task 2018-11-29T22:28:09.288Z] 22:28:09     INFO - 
[task 2018-11-29T22:28:09.288Z] 22:28:09     INFO - web-platform-tests                                           CT,, 
[task 2018-11-29T22:28:09.288Z] 22:28:09     INFO - 
[task 2018-11-29T22:28:10.843Z] 22:28:10     INFO - adb Granting important runtime permissions to org.mozilla.fennec_aurora
[task 2018-11-29T22:28:12.105Z] 22:28:12     INFO - adb launch_application: am start -W -n org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp -a android.intent.action.VIEW --es env9 MOZ_PROCESS_LOG=/tmp/tmp1vqfpCpidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4,MediaPipelineFactory:4 --es env10 R_LOG_LEVEL=6
[task 2018-11-29T22:28:13.462Z] 22:28:13     INFO - STDOUT: timed out waiting for 'org.mozilla.fennec_aurora' process to start
[task 2018-11-29T22:28:13.570Z] 22:28:13     INFO - Starting runner
It's unfortunate we don't have a stack trace or anything else that could help. It makes it really hard to diagnose this.

Aryx, do you know who owns these tests? Also this is tier 2, right?
Flags: needinfo?(aryx.bugmail)
I can think of one potential issue here, I'll Try server a fix and see if it helps.
@Aryx, thanks!

I also saw a Windows 7 Opt failure and it had a minidump I could load into minidump_stackwalk to get a stack trace. This confirms the crash is the one I mentioned in comment 3.

Try pushes also confirm a patch for that fixes this. I'll post a fix for this tomorrow.
Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
Flags: needinfo?(jdemooij)
Priority: P5 → P1
This is just a minor optimization, but it makes the bug fixed by part 2
reproducible when running jit-tests.
Blocks: 1499644
This was added in bug 833076 because back then TypeScript::SetThis assumed
non-null script->types. However since bug 875276 we don't need this anymore.
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa8de096f6dc
part 1 - Check script warm up count before calling ensureJitRealmExists in CanEnterBaselineJIT. r=tcampbell
https://hg.mozilla.org/integration/autoland/rev/30e5ba51f64a
part 2 - Ensure we have a JitRealm in ICScript::create. r=tcampbell
https://hg.mozilla.org/integration/autoland/rev/6cbbac93c273
part 3 - Remove unnecessary call to ensureHasTypes in jit::CreateThis. r=tcampbell
https://hg.mozilla.org/mozilla-central/rev/aa8de096f6dc
https://hg.mozilla.org/mozilla-central/rev/30e5ba51f64a
https://hg.mozilla.org/mozilla-central/rev/6cbbac93c273
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.