address bar drop-down should not take up the full width of the screen

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
8 months ago
3 months ago

People

(Reporter: billdillensrevenge, Unassigned)

Tracking

63 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

When you type in the address bar (or click the "Show history" arrow), the drop down takes up the full width of the screen. This is just strange and it shouldn't be this way. Edge and Chrome do not do this. See attached screenshots
Posted image chrome.png
Posted image edge.png
Hi Will,

Thanks for the report, will mark it as an enhancement for now.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → Address Bar
Ever confirmed: true
Thank you for the feedback, this is a design decision that pertains to our User Experience team, that has deep expertize on the matter, the fact other browsers are doing differently is a valid point, but it's just one of the many.
Next year we will be experimenting with the Address Bar and measure properly changes to it, so we may also be able to understand if our sizing behavior is damaging.
For now there's no plan to re-evaluate this design.
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WONTFIX
Thank you, please ask them to explore this next year during their address bar experiments!

Just updating this: Safari for macOS is the same as Chrome and Edge, so Firefox is the only major browser that has this strange full-screen width URL bar drop menu

Just as a note: the "non-full-width" was indeed always the standard for pretty much all browser (at least as far as I use(d) them since ~1999). Netscape, IE, Safari, Opera, Chrome, Edge, etc.
This newer full-width design in Firefox was only introduced two years or so ago.

Do you know why they did this though? I just can't think of a reason how or why this is better

Nope.

(In reply to Will from comment #8)

Do you know why they did this though? I just can't think of a reason how or why this is better

I'd argue that this is more an opinion and maybe you get an answer over at https://discourse.mozilla.org/c/nightly rather than via bugzilla. Good luck :)

You need to log in before you can comment on or make changes to this bug.