Crash in mozilla::ipc::FatalError | mozilla::ipc::IProtocol::HandleFatalError | mozilla::net::PNeckoChild::SendPHttpChannelConstructor

RESOLVED DUPLICATE of bug 1510715

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1510715
7 months ago
7 months ago

People

(Reporter: lizzard, Unassigned)

Tracking

({crash})

64 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 fixed)

Details

(crash signature)

This bug was filed from the Socorro interface and is
report bp-65d386b5-a4c4-434c-94b7-0b4220181129.
=============================================================

This signature started showing up in the 20181127100134  nightly build. 


Top 10 frames of crashing thread:

0 libxul.so MOZ_CrashOOL mfbt/Assertions.h:311
1 libxul.so mozilla::ipc::FatalError ipc/glue/ProtocolUtils.cpp:300
2 libxul.so mozilla::ipc::IProtocol::HandleFatalError const ipc/glue/ProtocolUtils.cpp:531
3 libxul.so mozilla::net::PNeckoChild::SendPHttpChannelConstructor ipc/ipdl/PNeckoChild.cpp:375
4 libxul.so mozilla::net::HttpChannelChild::InitIPCChannel netwerk/protocol/http/HttpChannelChild.cpp:2752
5 libxul.so mozilla::net::nsHttpHandler::NewProxiedChannel2 netwerk/protocol/http/nsHttpHandler.cpp:2236
6 libxul.so mozilla::net::nsIOService::NewChannelFromURIWithProxyFlagsInternal netwerk/base/nsIOService.cpp:861
7 libxul.so mozilla::net::nsIOService::NewChannelFromURIWithClientAndController netwerk/base/nsIOService.cpp:818
8 libxul.so <name omitted> netwerk/base/nsNetUtil.cpp:412
9 libxul.so NS_NewChannel netwerk/base/nsNetUtil.cpp:373

=============================================================
this one was cause by bug 1260527. The patch was backed out in bug 1510715.
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Flags: needinfo?(valentin.gosu)
Flags: needinfo?(valentin.gosu)
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1510715
You need to log in before you can comment on or make changes to this bug.