Also ignore breakpad client

RESOLVED FIXED in Firefox -esr60

Status

defect
RESOLVED FIXED
7 months ago
6 months ago

People

(Reporter: sylvestre, Assigned: sylvestre)

Tracking

(Blocks 1 bug)

unspecified
mozilla65
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 fixed, firefox65 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

7 months ago
I know it used to be thirdparty but now, it is mostly us.
However, because of bug 1510919, we are now supporting .cc and it breaks with

[task 2018-11-29T23:14:14.214Z] 23:14:14     INFO -  /builds/worker/workspace/build/src/sccache2/sccache /builds/worker/workspace/build/src/clang/bin/clang++ -target x86_64-apple-darwin11 -B /builds/worker/workspace/build/src/cctools/bin -isysroot /builds/worker/workspace/build/src/MacOSX10.11.sdk -o Unified_cpp_mac_handler0.o -c  -fvisibility=hidden -fvisibility-inlines-hidden -DDEBUG=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/toolkit/crashreporter/breakpad-client/mac/handler -I/builds/worker/workspace/build/src/obj-firefox/toolkit/crashreporter/breakpad-client/mac/handler -I/builds/worker/workspace/build/src/toolkit/crashreporter/breakpad-client -I/builds/worker/workspace/build/src/toolkit/crashreporter/google-breakpad/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wtautological-unsigned-enum-zero-compare -Wtautological-unsigned-zero-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=return-std-move -Wno-error=atomic-alignment -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -stdlib=libc++ -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -O3 -fno-omit-frame-pointer -funwind-tables -Werror  -MD -MP -MF .deps/Unified_cpp_mac_handler0.o.pp   /builds/worker/workspace/build/src/obj-firefox/toolkit/crashreporter/breakpad-client/mac/handler/Unified_cpp_mac_handler0.cpp
[task 2018-11-29T23:14:14.214Z] 23:14:14     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/toolkit/crashreporter/breakpad-client/mac/handler/Unified_cpp_mac_handler0.cpp:20:
[task 2018-11-29T23:14:14.214Z] 23:14:14    ERROR -  /builds/worker/workspace/build/src/toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:639:5: error: use of undeclared identifier 'X'
[task 2018-11-29T23:14:14.214Z] 23:14:14     INFO -    } catch (std::bad_alloc) {
[task 2018-11-29T23:14:14.214Z] 23:14:14     INFO -      ^
[task 2018-11-29T23:14:14.215Z] 23:14:14     INFO -  /builds/worker/workspace/build/src/toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:55:16: note: expanded from macro 'catch'
[task 2018-11-29T23:14:14.215Z] 23:14:14     INFO -  #define catch (X) if (false)
[task 2018-11-29T23:14:14.215Z] 23:14:14     INFO -                 ^
[task 2018-11-29T23:14:14.215Z] 23:14:14     INFO -  1 error generated.
Assignee

Comment 2

7 months ago
I did this try build.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=58845e21117d0b0756c2e001a8bf299cc83715b7

and I will have a look later about this issue.
Assignee

Updated

7 months ago
Duplicate of this bug: 1511213

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8e424cc86558
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65

Comment 5

6 months ago
Posted patch ESR patchSplinter Review
[ESR Uplift Approval Request]

If this is not a sec:{high,crit} bug, please state case for ESR consideration: This is required for easier backporting of patches after the reformatting of ESR using clang-format.

User impact if declined: Declining this will negatively impact our developers' ability to easily backport their patches to ESR in the future.

Fix Landed on Version: 65

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This is NPOTB.

String or UUID changes made by this patch: None
Attachment #9031020 - Flags: approval-mozilla-esr60?
Comment on attachment 9031020 [details] [diff] [review]
ESR patch

OK for uplift to ESR60 as part of the clang-format project.
Attachment #9031020 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
Target Milestone: Firefox 65 → mozilla65
You need to log in before you can comment on or make changes to this bug.