Closed Bug 1511455 Opened 9 months ago Closed 8 months ago

[Flexbox][Mini-map] - The min indication for a clamped element set to grow with flex-basis:0 is misplaced

Categories

(DevTools :: Inspector, defect, P3)

65 Branch
Unspecified
Windows
defect

Tracking

(firefox66 verified)

VERIFIED FIXED
Firefox 66
Tracking Status
firefox66 --- verified

People

(Reporter: paul.boiciuc, Assigned: mtigley)

Details

Attachments

(3 files)

Attached image min indication.PNG
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
Build ID: 20181129095546

STR:

1. Launch Firefox and navigate to https://developer.mozilla.org/en-US/docs/Web/CSS/flex-basis
2. Enable the element inspector.
3. From <div class "example-container"> select the "example-element" - flex basis:0
4. Navigate to the Flexbox Inspector section and observe the minimap of the Flex Item. 

[AR]

The "min" indication of the element (vertical bar) is in the wrong position.  

Note: This issue is not consistent. While testing with a fresh profile, it did not reproduce. After about 2 hours of testing on the same profile, I've noticed that the issue started to reproduce again. Could not reproduce it on Linux or Mac OS.

[ER]

The vertical bar next to the word “min” points to the same position as the one next to “final”.
Assignee: nobody → mtigley
Priority: -- → P3
I was able to replicate this.
Status: NEW → ASSIGNED
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/00466e6699d7
Draw the flex item outline's min point at correct position when set to grow. r=gl
https://hg.mozilla.org/mozilla-central/rev/00466e6699d7
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Flags: qe-verify+
QA Contact: cristian.comorasu
Attached image Capture.PNG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Verified as fixed using 66.0b7 DevEdition build 20190211185957.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.