Closed Bug 1511618 Opened 11 months ago Closed 10 months ago

PermaTier 2 Android tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js | Segmentation fault (code 139, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]

Categories

(Core :: JavaScript Engine: JIT, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
geckoview64 --- wontfix
firefox64 --- wontfix
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nbp)

References

Details

(Keywords: intermittent-failure, Whiteboard: [arm64:m1][geckoview:p1])

Attachments

(1 file)

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=215087705&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/RYHbYIY4QIySvxMJu4rU9g/runs/0/artifacts/public/logs/live_backing.log

16:15:28     INFO -  TEST-PASS | tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off") [0.3 s]
16:15:28     INFO -  {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off", "pid": 477, "source": "jittests", "test": "self-test/assertRecoveredOnBailout-1.js", "thread": "main", "time": 1543680928.2161071}
16:15:28     INFO -  {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off"}, "jitflags": "--ion-eager --ion-offthread-compile=off", "message": "Success", "pid": 477, "source": "jittests", "status": "PASS", "test": "self-test/assertRecoveredOnBailout-1.js", "thread": "main", "time": 1543680928.519289}
16:15:28     INFO -  exception output: Segmentation fault
16:15:28     INFO -  Segmentation faultSegmentation faultExit code: 139
16:15:28     INFO -  FAIL - self-test/assertRecoveredOnBailout-1.js
16:15:28  WARNING -  TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js | Segmentation fault (code 139, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]
16:15:28     INFO -  {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "pid": 477, "source": "jittests", "test": "self-test/assertRecoveredOnBailout-1.js", "thread": "main", "time": 1543680928.520023}
16:15:28     INFO -  {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads"}, "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "message": "Segmentation fault", "pid": 477, "source": "jittests", "status": "FAIL", "test": "self-test/assertRecoveredOnBailout-1.js", "thread": "main", "time": 1543680928.723086}
16:15:28     INFO -  INFO exit-status     : 139
16:15:28     INFO -  INFO timed-out       : False
16:15:28     INFO -  INFO stdout          > Segmentation fault
16:15:28     INFO -  INFO stderr         2> Segmentation fault
16:15:28     INFO -  TEST-PASS | tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js | Success (code 0, args "--baseline-eager") [0.2 s]
Summary: Intermittent Tier 2 Android tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js | Segmentation fault (code 139, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s] → PermaTier 2 Android tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js | Segmentation fault (code 139, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]
I saw these run on inbound over the weekend but I didn't understand why they would do so since they are only enabled for try. They were classified as infra so I assumed it was some extraneous issue which caused them to run. These failures are known and tracked in bug 1475648 and bug 1454918. This should be marked invalid or duped to one of the other jit bugs for android-hw.
Flags: needinfo?(bob)
This test failure affects both ARMv7 and ARM64 and is blocking us from enabling ARM jit-tests in automation.
OS: Unspecified → Android
Priority: P5 → --
Hardware: Unspecified → ARM
Whiteboard: [arm64:m1][geckoview:p1]
This is checking that we doing some optimization in IonMonkey, until we get IonMonkey working on ARM64, I will suggest to disable the test on ARM64 until we get IonMonkey working there.
Assignee: nobody → nicolas.b.pierron
Status: NEW → ASSIGNED
Comment 6 suggests this also applies to ARM 32-bit FWIW...
Testing locally with patches to re-enable ARM64 IonMonkey backend, I am unable to reproduce this issue both on ARM64 and simulator.

However, what is weird is:

(In reply to Treeherder Bug Filer from comment #0)
> 16:15:28     INFO -  TEST-PASS |
> tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js |
> Success (code 0, args "--ion-eager --ion-offthread-compile=off") [0.3 s]

This should be the failure! An exit code of 0 on a test which is expected to crash is a failure.

> 16:15:28  WARNING -  TEST-UNEXPECTED-FAIL |
> tests/jit-test/jit-test/tests/self-test/assertRecoveredOnBailout-1.js |
> Segmentation fault (code 139, args "--ion-eager --ion-offthread-compile=off
> --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2
> s]

While this should be a successful run.
(In reply to Nicolas B. Pierron [:nbp] from comment #9)
> Testing locally with patches to re-enable ARM64 IonMonkey backend

Testing locally without these patches, I am still unable to reproduce on a simulator build.
I will try on a native build tomorrow.
Trying with no patches, I still cannot reproduce natively on ARM64.

I wonder if this is not just an error with running tests remotely.
Dan, would you be able to run the jit-test remotely, only on the self-test directory, and report if you are able to reproduce this issue? Or point me to the documentation to do the cross-compilation and remote testing procedure.

I failed to reproduce this issue when testing locally (on ARM64, and x64 ARM64-simulator), and I do not have anything setup for testing remotely.
Flags: needinfo?(dminor)
I'm sorry, I haven't worked on automation and testing for a few years and I'm no longer very familiar with the test harness or the remote testing procedure. I'm redirecting to Joel, I think someone on his team would be in a better position to help out.
Flags: needinfo?(dminor) → needinfo?(jmaher)
:bc, can you look at this when finished with the battery test- I think we are getting closer to something actionable here and maybe there is something to fix in the remote setup or output handling.
Flags: needinfo?(jmaher) → needinfo?(bob)
64=wontfix because we probably don't need to uplift the fix to the GV 64 relbranch.
I've reproduced the issue with the exit code on a test with an expected failure. Investigating. Worst case, I can work around it.
Depends on: 1516913
Flags: needinfo?(bob)
Attachment #9033713 - Flags: review?(jmaher)
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2bdcac07076a
js/src/tests/lib/jittests.py check_output should detect rc 139 as a crash, r=jmaher.
https://hg.mozilla.org/mozilla-central/rev/2bdcac07076a
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
See Also: → 1545537
You need to log in before you can comment on or make changes to this bug.