Closed Bug 1511704 Opened Last year Closed 10 months ago

Port bug 1506835: The buttons under the languages list are not visible if several languages are added to the list

Categories

(Thunderbird :: Preferences, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 65.0

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(2 files)

We don't use this warning because the automatic dictionaties download isn't implemented yet. But to be in sync as much, we can port it.
We are a bit different in the dialog as we flex the richlistbox also vertically and don't have a fixed box height which looks weirs when you make the dialog taller. I also added a separator between the content and the button on bottom to look a bit better.

Port of https://hg.mozilla.org/mozilla-central/rev/5f0040d4be16 with some styles added to let the buttons align better.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9029197 - Flags: review?(jorgk)
Comment on attachment 9029197 [details] [diff] [review]
1511704-expand-languages-dialog.patch

Should I see a difference? I didn't download lots of language packs to reproduce the original issue, did you?
Attachment #9029197 - Flags: review?(jorgk) → review+
We should see only something when the warning is shown. But we don't support dictionary downloads yet so the warning is never shown.
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/894ad5c9dce3
Port bug 1506835: The buttons under the languages list are not visible if several languages are added to the list. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0

I'm using TB 65.0b2, and I still don't see any language other than English, even though I installed German and French.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Patrick, can you add a screenshot? The dialog can also be made bigger with the resizer on bottom right.

Attached image Screenshot.png

Hmm... I'm not sure if we talk about the same "Language" dialog. I'm talking about the spell-checking (as attached). Should I open a different bug for it?

It's not the same dialog. The one from this bug is in the preferences for selecting other locales for the UI. Please file a new bug.

Status: REOPENED → RESOLVED
Closed: 11 months ago10 months ago
Resolution: --- → FIXED

(In reply to Patrick Brunschwig from comment #5)

I'm using TB 65.0b2, and I still don't see any language other than English, even though I installed German and French.

I think you have "Classic" dictionaries installed, but you need WebExtension dictionaries. And you need to read the release notes ;-)
https://www.thunderbird.net/en-US/thunderbird/65.0beta/releasenotes/

DICTIONARY SUPPORT: Only WebExtension dictionaries are supported now. Please download new dictionaries from addons.mozilla.org since addons.thunderbird.net still provides "legacy" dictionaries compatible with Thunderbird 60 ESR. This may change as soon as Thunderbird 60 ESR can also handle WebExtension dictionaries (planned for version 60.5).

Type: enhancement → task
You need to log in before you can comment on or make changes to this bug.