Browser crashes when pointed to java.sun.com

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: richard, Assigned: joe.chou)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
No error is displayed, process just quits. I'm using Mozilla 1.0.0 on a plain
Debian woody box. JRE is 1.3.1.
master question #1 : Have you correctly symlinked the plugin or copied ?

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 2

17 years ago
just copying it shouldn't register it as a plugin, -> it shouldn't die.
What JRE are you using? (sun? blackdown?)
Is the JRE registering correctly? (shows up in help -> about plugins)
Does it crash with any other java applets? 
(try http://alge.nlc.no/~alge/java/valuta.java )
Do you have a ~/plugin131.trace file?
Assignee: Matti → joe.chou
Component: Browser-General → OJI
QA Contact: imajes-qa → pmac
>just copying it shouldn't register it as a plugin, -> it shouldn't die
It dies and mozilla can't do anything because the plugin just calls Exit()

Search and you will find the comment from sun about this.
(Reporter)

Comment 4

17 years ago
Created attachment 87484 [details]
plugin131.trace
(Reporter)

Comment 5

17 years ago
The plugin registers fine:

File name: /usr/lib/mozilla/plugins/libjavaplugin_oji.so
Java(TM) Plug-in1.3.1

I'm uploading my ~/plugin131.trace next.
(Reporter)

Comment 6

17 years ago
I get a 404 on http://alge.nlc.no/~alge/java/valuta.java

What do you mean with "plugin just calls Exit()"? Shouldn't all other browsers
(IE, Opera) also exit then? And no, I cannot find the comments of Sun about
this. Please submit the URL that you found this information at.
IE = invalid (because windows)

Can you please answer my question ?
*Have you symlinked the plugin or copied ?*

Search yourself in bugzilla for the SUN developer comment about this.

And that mozilla crashes if the plugin calls exit() :
EXIT(3) Linux Programmer's Manual             EXIT(3)
NAME
 exit - cause normal program termination
DESCRIPTION
 The  exit()  function  causes  normal program termination and the value of
 status is returned to the parent.  All functions registered with  atexit()
 and  on_exit()  are called in the reverse order of their registration, and
 all open streams are flushed and closed.
---
that means if java plugin, which is running in brower's
process space, calls exit() the whole process will be terminated


(Reporter)

Comment 8

17 years ago
Ok, I think I found my problem. I had both a symlink and a static copy of the
plugin in /usr/lib/mozilla/plugins. The symlink is: 

javaplugin_oji.so -> /etc/alternatives/javaplugin_oji.so

which is created by the j2sdk1.3 Debian package from Blackdown. The static
version was libjavaplugin_oji.so, god knowns how/where I got it. Deleting the
static version resolved my issue with visiting java.sun.com

For the record, I think I found the reference to the exit() discussion here:
http://bugzilla.mozilla.org/show_bug.cgi?id=134568

Thanks for your help, my problem is solved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.