Closed Bug 1511797 Opened 11 months ago Closed 11 months ago

11-15% talos (linux64-qr, windows-qr) regression on push 55abd0f51161498eaa0c5a875895a54179c52b73 (Thu Nov 29 2018)

Categories

(Core :: Graphics: WebRender, defect)

65 Branch
x86_64
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed

People

(Reporter: Bebe, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

(Keywords: perf, regression, talos-regression)

Attachments

(1 file)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=55abd0f51161498eaa0c5a875895a54179c52b73

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 11%  tscrollx linux64-qr opt e10s stylo     2.31 -> 2.58


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=17921

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling
Blocks: 1510899
Component: General → Graphics: WebRender
Product: Testing → Core
Target Milestone: --- → mozilla65
Version: Version 3 → 65 Branch
Blocks: 1500846
:mattwoodrow can you take a look over this?
Flags: needinfo?(matt.woodrow)
The bug summary and comment 0 only mentions Linux regressions which are very low priority for us right now. If this bug covers Windows regressions as well please make that explicit from the start.
Flags: needinfo?(fstrugariu)
OS: Unspecified → All
Hardware: Unspecified → x86_64
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> The bug summary and comment 0 only mentions Linux regressions which are very
> low priority for us right now. If this bug covers Windows regressions as
> well please make that explicit from the start.

Sorry about that. The updated list with the regressions is the one bellow. Windows 10 QR was more affected than Linux.

== Change summary for alert #17921 (as of Thu, 29 Nov 2018 17:41:04 GMT) ==

Regressions:

 15%  tscrollx windows10-64-qr opt e10s stylo        1.11 -> 1.28
 13%  tart windows10-64-qr opt e10s stylo            2.84 -> 3.22
 11%  tscrollx linux64-qr opt e10s stylo             2.31 -> 2.58
 11%  tp5o_scroll linux64-qr opt e10s stylo          4.35 -> 4.82
 11%  tp5o_scroll windows10-64-qr opt e10s stylo     2.46 -> 2.73
  3%  tart linux64-qr opt e10s stylo                 4.16 -> 4.29

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=17921
Sorry for the misleading information.  looks like :igoldan added the necessary information

Bebe
Flags: needinfo?(fstrugariu)
Summary: 11.48% tscrollx (linux64-qr) regression on push 55abd0f51161498eaa0c5a875895a54179c52b73 (Thu Nov 29 2018) → 11-15% talos (linux64-qr, windows-qr) regression on push 55abd0f51161498eaa0c5a875895a54179c52b73 (Thu Nov 29 2018)
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a58e3e8aab98
Allow catch up compositing to continue when we complete frame building. r=sotaro
https://hg.mozilla.org/mozilla-central/rev/a58e3e8aab98
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
All regressions form comment #0 has been fixed.

This is just a part of the fixes:

== Change summary for alert #18067 (as of Thu, 06 Dec 2018 20:37:56 GMT) ==

Improvements:

 12%  tscrollx linux64-qr opt e10s stylo     2.58 -> 2.26
  3%  tart linux64-qr opt e10s stylo         4.16 -> 4.05

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=18067



Nice job Matt Woodrow (:mattwoodrow)
Status: RESOLVED → VERIFIED
See Also: → 1513254
This improved our performance 
== Change summary for alert #18150 (as of Wed, 12 Dec 2018 12:29:40 GMT) ==

Improvements:

 20%  tp5o_scroll opt e10s stylo     3.56 -> 2.84
 20%  tscrollx opt e10s stylo        2.25 -> 1.80
 10%  tp5o_scroll opt e10s stylo     2.18 -> 1.96

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=18150
You need to log in before you can comment on or make changes to this bug.