Status

()

enhancement
RESOLVED FIXED
6 months ago
2 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

(Depends on 1 bug)

unspecified
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

No description provided.

Comment 1

6 months ago
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f5851346109d
Remove useless GECKO_BORROWED_TYPE_MUT.
https://hg.mozilla.org/integration/mozilla-inbound/rev/29c8ec1559a4
Update syn and related dependencies. r=emilio
https://hg.mozilla.org/integration/mozilla-inbound/rev/ddd573878432
Update bindgen.
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2c997426108
Revendor Rust dependencies.
https://hg.mozilla.org/integration/mozilla-inbound/rev/7bc486fbd195
Rustfmt new changes to ensure Servo-tidy doesn't complain.
https://hg.mozilla.org/integration/mozilla-inbound/rev/2392d8199cd0
Use https for the MPL license URL.
https://hg.mozilla.org/integration/mozilla-inbound/rev/800bc60c75a7
Make page-break-* Gecko-only.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5fe23889cccc
Update mozjs and enable 'init_once' feature for Android.
https://hg.mozilla.org/integration/mozilla-inbound/rev/da7816ec50ef
Update Servo's version of encoding_rs.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a08148928ef
Update crossbeam-channel to 0.3.
https://hg.mozilla.org/integration/mozilla-inbound/rev/53d1f5ca4099
Fix formatting of inverse transform matrix to appease tidy.
https://hg.mozilla.org/integration/mozilla-inbound/rev/0ae2634de8e1
Go back to bindgen 0.43 since I can't manage to make the tup build succeed.
https://hg.mozilla.org/integration/mozilla-inbound/rev/d71cde918f43
Minor build fixup after the Servo crossbeam_channel update.
Backed out 13 changesets (Bug 1511811) for Btup bustages

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&selectedJob=215271356

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=215271356&repo=mozilla-inbound&lineNumber=2125

[task 2018-12-03T13:27:21.890Z] 13:27:21     INFO -   *** Command ran successfully, but failed due to errors processing input dependencies.
[task 2018-12-03T13:27:22.843Z] 13:27:22     INFO -  * ~76%  3612) obj-firefox/toolkit/library/rust: PYTHONDONTWRITEBYTECODE=1 /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python -m mozbuild.action.wrap_rustc --crate-out --deps-out /builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/build/encoding_rs-6d70d03ca9a1b3a0/out/encoding_rs_Target_build_out.txt /builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/build/simd-7853425cdec7f898/out/simd_Target_build_out.txt --cwd /builds/worker/workspace/build/src --pass-l-flag --cmd env MOZ_CARGO_WRAP_LD='/builds/worker/workspace/build/src/clang/bin/clang -std=gnu99' MOZ_DIST=/builds/worker/workspace/build/src/obj-firefox/dist PKG_CONFIG_ALLOW_CROSS=1 RUSTC_BOOTSTRAP=1 PYTHON=/builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python MOZ_AUTOMATION=1 PYTHONDONTWRITEBYTECODE=1 RUST_BACKTRACE=full MOZ_TOPOBJDIR=/builds/worker/workspace/build/src/obj-firefox CARGO_TARGET_DIR=/builds/worker/workspace/build/src/obj-firefox CLANG_PATH=/builds/worker/workspace/build/src/clang/bin/clang CARGO_INCREMENTAL=0 LIBCLANG_PATH=/builds/worker/workspace/build/src/clang/lib MOZ_CARGO_WRAP_LDFLAGS='-lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions -Wl,--build-id=sha1 -Wl,-rpath-link,/builds/worker/workspace/build/src/obj-firefox/dist/bin -Wl,-rpath-link,/usr/local/lib' CARGO_TARGET_X86_64_UNKNOWN_LINUX_GNU_LINKER=/builds/worker/workspace/build/src/build/cargo-linker RUSTC=/builds/worker/workspace/build/src/rustc/bin/rustc MOZ_SRC=/builds/worker/workspace/build/src RUSTFLAGS='-C opt-level=2 -C debuginfo=2 ' CARGO=/builds/worker/workspace/build/src/rustc/bin/cargo CARGO_PKG_VERSION_MAJOR=0 CARGO_PKG_HOMEPAGE='' CARGO_PKG_DESCRIPTION='' CARGO_MANIFEST_DIR=/builds/worker/workspace/build/src/netwerk/base/mozurl CARGO_PKG_NAME=mozurl CARGO_PKG_AUTHORS='Nika Layzell <nika@thelayzells.com>' CARGO_PKG_VERSION=0.0.1 CARGO_PKG_VERSION_PATCH=1 CARGO_PKG_VERSION_PRE='' LD_LIBRARY_PATH=/builds/worker/workspace/build/src/obj-firefox/release/deps:/builds/worker/workspace/build/src/rustc/lib CARGO_PKG_VERSION_MINOR=0 /builds/worker/workspace/build/src/rustc/bin/rustc --crate-name mozurl netwerk/base/mozurl/src/lib.rs --color never --crate-type lib --emit=link -C opt-level=2 -C panic=abort -C codegen-units=1 -C metadata=bbae56702e484f04 -C extra-filename=-bbae56702e484f04 --out-dir /builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps --target x86_64-unknown-linux-gnu -C linker=/builds/worker/workspace/build/src/build/cargo-linker -L dependency=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps -L dependency=/builds/worker/workspace/build/src/obj-firefox/release/deps --extern nserror=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/libnserror-5362640fb7d8f680.rlib --extern nsstring=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/libnsstring-f57b98d3771e768c.rlib --extern url=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/liburl-d6b831029ac7535e.rlib --extern xpcom=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/libxpcom-985661b612240474.rlib -C opt-level=2 -C debuginfo=2
[task 2018-12-03T13:27:22.843Z] 13:27:22     INFO -   *** tup messages ***
[task 2018-12-03T13:27:22.843Z] 13:27:22     INFO -  tup error: Missing input dependency - a file was read from, and was not specified as an input link for the command. This is an issue because the file was created from another command, and without the input link the commands may execute out of order. You should add this file as an input, since it is possible this could randomly break in the future.
[task 2018-12-03T13:27:22.844Z] 13:27:22     INFO -   - [351698] obj-firefox/release/deps/libxpcom_macros-76fb3e5282fd672c.so
[task 2018-12-03T13:27:22.844Z] 13:27:22     INFO -   *** Command ran successfully, but failed due to errors processing input dependencies.
[task 2018-12-03T13:27:23.043Z] 13:27:23     INFO -  * ~76%  3611) obj-firefox/toolkit/library/rust: PYTHONDONTWRITEBYTECODE=1 /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python -m mozbuild.action.wrap_rustc --crate-out --deps-out /builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/build/encoding_rs-6d70d03ca9a1b3a0/out/encoding_rs_Target_build_out.txt /builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/build/simd-7853425cdec7f898/out/simd_Target_build_out.txt --cwd /builds/worker/workspace/build/src --pass-l-flag --cmd env MOZ_CARGO_WRAP_LD='/builds/worker/workspace/build/src/clang/bin/clang -std=gnu99' MOZ_DIST=/builds/worker/workspace/build/src/obj-firefox/dist PKG_CONFIG_ALLOW_CROSS=1 RUSTC_BOOTSTRAP=1 PYTHON=/builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python MOZ_AUTOMATION=1 PYTHONDONTWRITEBYTECODE=1 RUST_BACKTRACE=full MOZ_TOPOBJDIR=/builds/worker/workspace/build/src/obj-firefox CARGO_TARGET_DIR=/builds/worker/workspace/build/src/obj-firefox CLANG_PATH=/builds/worker/workspace/build/src/clang/bin/clang CARGO_INCREMENTAL=0 LIBCLANG_PATH=/builds/worker/workspace/build/src/clang/lib MOZ_CARGO_WRAP_LDFLAGS='-lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions -Wl,--build-id=sha1 -Wl,-rpath-link,/builds/worker/workspace/build/src/obj-firefox/dist/bin -Wl,-rpath-link,/usr/local/lib' CARGO_TARGET_X86_64_UNKNOWN_LINUX_GNU_LINKER=/builds/worker/workspace/build/src/build/cargo-linker RUSTC=/builds/worker/workspace/build/src/rustc/bin/rustc MOZ_SRC=/builds/worker/workspace/build/src RUSTFLAGS='-C opt-level=2 -C debuginfo=2 ' CARGO=/builds/worker/workspace/build/src/rustc/bin/cargo CARGO_PKG_VERSION_MAJOR=0 CARGO_PKG_HOMEPAGE='' CARGO_PKG_DESCRIPTION='' CARGO_MANIFEST_DIR=/builds/worker/workspace/build/src/netwerk/base/mozurl CARGO_PKG_NAME=mozurl CARGO_PKG_AUTHORS='Nika Layzell <nika@thelayzells.com>' CARGO_PKG_VERSION=0.0.1 CARGO_PKG_VERSION_PATCH=1 CARGO_PKG_VERSION_PRE='' LD_LIBRARY_PATH=/builds/worker/workspace/build/src/obj-firefox/release/deps:/builds/worker/workspace/build/src/rustc/lib CARGO_PKG_VERSION_MINOR=0 /builds/worker/workspace/build/src/rustc/bin/rustc --crate-name mozurl netwerk/base/mozurl/src/lib.rs --color never --crate-type lib --emit=link -C opt-level=2 -C panic=abort -C codegen-units=1 -C metadata=7c65fff427d63dc3 -C extra-filename=-7c65fff427d63dc3 --out-dir /builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps --target x86_64-unknown-linux-gnu -C linker=/builds/worker/workspace/build/src/build/cargo-linker -L dependency=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps -L dependency=/builds/worker/workspace/build/src/obj-firefox/release/deps --extern nserror=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/libnserror-5362640fb7d8f680.rlib --extern nsstring=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/libnsstring-f57b98d3771e768c.rlib --extern url=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/liburl-d6b831029ac7535e.rlib --extern xpcom=/builds/worker/workspace/build/src/obj-firefox/x86_64-unknown-linux-gnu/release/deps/libxpcom-24675f0c4b0b5efe.rlib -C opt-level=2 -C debuginfo=2
[task 2018-12-03T13:27:23.043Z] 13:27:23     INFO -   *** tup messages ***
[task 2018-12-03T13:27:23.043Z] 13:27:23     INFO -  tup error: Missing input dependency - a file was read from, and was not specified as an input link for the command. This is an issue because the file was created from another command, and without the input link the commands may execute out of order. You should add this file as an input, since it is possible this could randomly break in the future.
[task 2018-12-03T13:27:23.043Z] 13:27:23     INFO -   - [351365] obj-firefox/release/deps/libxpcom_macros-c7f78977f0e23ab1.so
[task 2018-12-03T13:27:23.043Z] 13:27:23     INFO -   *** Command ran successfully, but failed due to errors processing input dependencies.
[task 2018-12-03T13:27:52.338Z] 13:27:52     INFO -   *** tup: 3 jobs failed.
[task 2018-12-03T13:27:52.378Z] 13:27:52     INFO -  49 compiler warnings present.
[task 2018-12-03T13:27:52.386Z] 13:27:52     INFO -  Notification center failed: Install notify-send (usually part of the libnotify package) to get a notification when the build finishes.
[task 2018-12-03T13:27:52.448Z] 13:27:52    ERROR - Return code: 1
[task 2018-12-03T13:27:52.448Z] 13:27:52  WARNING - setting return code to 2
[task 2018-12-03T13:27:52.449Z] 13:27:52    FATAL - 'mach build -v' did not run successfully. Please check log for errors.
[task 2018-12-03T13:27:52.449Z] 13:27:52    FATAL - Running post_fatal callback...
[task 2018-12-03T13:27:52.449Z] 13:27:52    FATAL - Exiting -1
[task 2018-12-03T13:27:52.449Z] 13:27:52     INFO - [mozharness: 2018-12-03 13:27:52.449390Z] Finished build step (failed)
[task 2018-12-03T13:27:52.449Z] 13:27:52     INFO - Running post-run listener: _shutdown_sccache
[task 2018-12-03T13:27:52.449Z] 13:27:52     INFO - Running command: ['/builds/worker/workspace/build/src/sccache2/sccache', '--stop-server'] in /builds/worker/workspace/build/src
[task 2018-12-03T13:27:52.449Z] 13:27:52     INFO - Copy/paste: /builds/worker/workspace/build/src/sccache2/sccache --stop-server
[task 2018-12-03T13:27:52.453Z] 13:27:52     INFO -  Stopping sccache server...
[task 2018-12-03T13:27:52.453Z] 13:27:52     INFO -  error: couldn't connect to server
[task 2018-12-03T13:27:52.453Z] 13:27:52     INFO -  caused by: Connection refused (os error 111)
[task 2018-12-03T13:27:52.453Z] 13:27:52    ERROR - Return code: 2
[task 2018-12-03T13:27:52.453Z] 13:27:52     INFO - Running post-run listener: _summarize
[task 2018-12-03T13:27:52.453Z] 13:27:52    ERROR - # TBPL FAILURE #
[task 2018-12-03T13:27:52.453Z] 13:27:52     INFO - [mozharness: 2018-12-03 13:27:52.453929Z] FxDesktopBuild summary:
[task 2018-12-03T13:27:52.454Z] 13:27:52    ERROR - # TBPL FAILURE #
[task 2018-12-03T13:27:52.460Z] cleanup
[task 2018-12-03T13:27:52.460Z] + cleanup
[task 2018-12-03T13:27:52.460Z] + local rv=255
[task 2018-12-03T13:27:52.460Z] + cleanup_xvfb
[task 2018-12-03T13:27:52.460Z] pidof Xvfb
[task 2018-12-03T13:27:52.460Z] ++ pidof Xvfb
[task 2018-12-03T13:27:52.461Z] + local xvfb_pid=52
[task 2018-12-03T13:27:52.461Z] + local vnc=false
[task 2018-12-03T13:27:52.462Z] + local interactive=false
[task 2018-12-03T13:27:52.462Z] + '[' -n 52 ']'
[task 2018-12-03T13:27:52.462Z] + [[ false == false ]]
[task 2018-12-03T13:27:52.462Z] + [[ false == false ]]
[task 2018-12-03T13:27:52.462Z] + kill 52
[task 2018-12-03T13:27:52.462Z] + screen -XS xvfb quit
[task 2018-12-03T13:27:52.595Z] No screen session found.
[task 2018-12-03T13:27:52.595Z] + true
[task 2018-12-03T13:27:52.595Z] + exit 255
[taskcluster 2018-12-03 13:27:52.892Z] === Task Finished ===
Flags: needinfo?(emilio)
Assignee

Comment 4

6 months ago
I'll land most of the code changes now that shouldn't affect tup.
Keywords: leave-open

Comment 5

6 months ago
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f713c586d397
Backed out 13 changesets for Btup bustages

Comment 6

6 months ago
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4a9fe235c6b0
Update mozjs and enable 'init_once' feature for Android.
https://hg.mozilla.org/integration/mozilla-inbound/rev/7a36832beb55
Update Servo's version of encoding_rs.
https://hg.mozilla.org/integration/mozilla-inbound/rev/eeef84fe603d
Update crossbeam-channel to 0.3.
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc9324a80fac
Minor build fixup after the Servo crossbeam_channel update.
Assignee

Updated

6 months ago
Depends on: 1511830
Assignee

Updated

6 months ago
Depends on: 1512041
Assignee

Updated

6 months ago
Flags: needinfo?(emilio)
Assignee

Updated

6 months ago
Keywords: leave-open

Comment 9

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4fc3f968d0b6
https://hg.mozilla.org/mozilla-central/rev/6a4b98caa59b
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Depends on: 1513173
No longer depends on: 1513173
Regressions: 1513173
You need to log in before you can comment on or make changes to this bug.