Closed Bug 1511819 Opened 1 year ago Closed 1 year ago

Reduce confusion in about:preferences when enabling session restore and disabling tab close warning prompts

Categories

(Firefox :: Preferences, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 66
Tracking Status
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

Attachments

(1 file)

(In reply to Amy Lee [:amylee] UX from bug 1506173 comment #33)
> (In reply to :Gijs (he/him) from bug 1506173 comment #32)
> > 1) The two checkboxes in the prefs can IMO be confusing if you enable
> > session store, turn off warning for closing tabs (from the dialog when
> > closing a window or otherwise closing more than 1 tab), and turn on warning
> > for quitting underneath the session store pref. You end up with 2 checkboxes
> > that both mention warning when quitting, one ticked and one unticked. I
> > don't really know what the right solution to that problem is. Per discussion
> > with UX, we *do* want to show the quit warning in that case (so the
> > sessionstore-specific pref "overrides" the multiple-tabs pref) but I don't
> > know how to make that clear in the UI, because the multiple tabs pref still
> > controls whether we show a warning when closing a window / multiple tabs
> > (but not quitting).
> 
> I'm wondering if we should remove "quitting" and only say "Warn me when
> closing multiple tabs" and keep the checkbox under session restore as "warn
> me when quitting the browser". NI Meridel for her input. 

We could potentially also have 2 labels for the "Warn me when closing multiple tabs" item, one that includes "Quitting", and one that doesn't, and only show the former while session restore is not enabled (changing the label when the user ticks "Restore previous session". This would be accurate in that that is what the pref does in those separate circumstances.

(Carrying over needinfo from bug 1506173)
Flags: needinfo?(mwalkington)
Priority: -- → P3
Meridel, Amy and I talked about this today, and we'll just remove the "Quitting" bit of the label for the "closing multiple tabs" warning.

:flod, on (65) release, this string looks like this in en-US:


warn-on-close-multiple-tabs =
    .label = Warn you when closing multiple tabs
    .accesskey = m

on nightly, it looks like this:

warn-on-quit-close-multiple-tabs =
    .label = Warn you when quitting and closing multiple tabs
    .accesskey = m


What's the right ID here when I change the string back to the release version? Can I reuse the ID (esp given the string contents will be the same again), or not?
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(mwalkington) → needinfo?(francesco.lodolo)
(In reply to :Gijs (he/him) from comment #1)
> What's the right ID here when I change the string back to the release
> version? Can I reuse the ID (esp given the string contents will be the same
> again), or not?

In this specific case you can reuse the same ID.

The cross-channel l10n repository includes strings from 64 (release) to 66 (nightly), so that string is still available in localization repositories. 
https://hg.mozilla.org/l10n/gecko-strings/file/c02c115d93d1/browser/browser/preferences/preferences.ftl#l187

Adding it back to English wouldn't require a new translation, so it would be fine even to uplift.
Flags: needinfo?(francesco.lodolo)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5a1ffa97bd6e
update preference label for warning for closing multiple tabs, r=flod
https://hg.mozilla.org/mozilla-central/rev/5a1ffa97bd6e
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Comment on attachment 9030480 [details]
Bug 1511819 - update preference label for warning for closing multiple tabs, r?flod

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1506173

User impact if declined: Possible confusion in the user preferences because of 2 similarly named but distinct checkboxes

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This is basically just reverting a string change, so it's very safe.

(In reply to Francesco Lodolo [:flod] from comment #2)
> Adding it back to English wouldn't require a new translation, so it would be
> fine even to uplift.

String changes made/needed: Yes, but should be fine because we're just restoring a string that we had in 64, so it's still in the l10n repos
Attachment #9030480 - Flags: approval-mozilla-beta?
> > Adding it back to English wouldn't require a new translation, so it would be
> > fine even to uplift.
> 
> String changes made/needed: Yes, but should be fine because we're just
> restoring a string that we had in 64, so it's still in the l10n repos

Just confirming that it's fine to uplift.
Comment on attachment 9030480 [details]
Bug 1511819 - update preference label for warning for closing multiple tabs, r?flod

[Triage Comment]
Fixes a confusingly-labeled checkbox in the preferences. String changes approved by Flod. Approved for 65.0b5.
Attachment #9030480 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.