[Wayland] Key shortcuts (ALT+num) do not work

RESOLVED FIXED in Firefox 65

Status

()

defect
P2
normal
RESOLVED FIXED
9 months ago
3 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla65
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(1 attachment)

The key shortcuts (key mapping) do not work in latest Nighly after Bug 1511011 landed.
We can't listen on GdkDeviceManager as we need to track device changes here. Rvert back
the old working setup based on wl_seat listeners. Also check if the keyboard is already present
(before it's created here) to avoid memory leaks.
Keywords: checkin-needed
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d932537fec3b
[Wayland] Listen for keyboard layout changes on wl_seat again, r=jhorak
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d932537fec3b
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65

This is still not working on nightly, 67.0a1 (2019-02-03) (64-bit) under wayland.

I'm also seeing this on Firefox 66.0b6 developer edition under Wayland, build 20190208180655.

I'm also experiencing this bug in Wayland using 67.0a1 (2019-02-11).

(In reply to Geoff Greer from comment #6)

I'm also experiencing this bug in Wayland using 67.0a1 (2019-02-11).

Can I ask which window manager are you using? I've realized I'm seeing this issue only when using Sway, but not with GNOME on Wayland.

I'm using Sway. Alt + num does work in other applications such as gnome-terminal. Also, hitting alt in Firefox toggles the menu bar at the top of the window.

Please file a new bug for it and state your compositor (I expect Sway, correct?). Thanks.

Duplicate of this bug: 1475802
You need to log in before you can comment on or make changes to this bug.