Closed Bug 1512046 Opened 10 months ago Closed 9 months ago

Click on callstack grouped frames shouldn't propagate

Categories

(DevTools :: Console, defect, P1)

65 Branch
defect

Tracking

(firefox65 verified)

VERIFIED FIXED
Firefox 65
Tracking Status
firefox65 --- verified

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Details

Attachments

(1 file)

**Steps to reproduce**
1. Open the console
2. Evaluate the following: 

```
x = new Error("ooops")
x.stack = "a@http://exampl.com:1:1\n" +
    "grouped@http://react.js:1:1\n" +
    "grouped2@http://react.js:1:1";
console.error(x)
```
3. You should see a callstack with a React group, click on it


**Expected results**

The group is expanded

**Actual results**

The group is expanded, but so is the message (the arrow icon on the left is rotated, and the console.error callstack is displayed under the react callstack)

---

This is because the group click propagates, which shouldn't.
This also adds a console test to make sure we don't regress
this in the future.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a9c528fe96d5
Stop propagation of callstack group click; r=Honza.
Erf, probably Bug 1508549 caused that.
I fixed the test and pushed to TRY again: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6e36591434de912c09c10e7d0d0c97c79dbcbfdd
Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d93612673dc
Stop propagation of callstack group click; r=Honza.
https://hg.mozilla.org/mozilla-central/rev/1d93612673dc
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+

I reproduced this issue using Fx 65.0a1, build ID: 20181204215402, on Windows 10 x64 and Ubuntu 18.04.1 LTS.

I can confirm this issue is fixed, I verified using Fx 65.0b12, build ID: 20190117232427, on Windows 10 x64, macOS X 10.13 and Ubuntu 18.04.1 LTS.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.