Closed Bug 1512085 Opened 2 years ago Closed 2 years ago

ID Conflict between Content and Middleman process

Categories

(Core Graveyard :: Web Replay, enhancement)

enhancement
Not set
normal

Tracking

(firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: nika, Assigned: nika)

References

Details

Attachments

(1 file)

Currently if an actor or window is created in the middleman process, it may have an ID which conflicts with another actor or window in the observed process. This avoids that issue by using a bit to specify that the process is a middleman.

This is the cause of the assertion failure which caused bug 1487249 to be backed out.
Pushed by nika@thelayzells.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3c4afc3c780
Don't overlap IDs between content and middleman process, r=bhackett
https://hg.mozilla.org/mozilla-central/rev/f3c4afc3c780
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.