Closed Bug 1512086 Opened 11 months ago Closed 11 months ago

Console ElementHighlighter does not work

Categories

(DevTools :: Console, defect, P2)

65 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 verified)

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: nchevobbe, Assigned: yulia)

References

Details

(Keywords: regression)

Attachments

(1 file)

**Steps to reproduce**
1. Go to `data:text/html,<meta charset=utf8>`
2. Open the console (directly, it's important)
3. Evaluate `document.body`
4. In the output, hover the `<body>` element

**Expected results**

The body is highlighted in the content page

**Actual results**

The highlighter does not work

---

Note that it works if at some point you open the inspector.
Oh this is bad. I would probably prioritize this higher than a P3. This is a major feature of the console that just doesn't work anymore.
I'm currently running a mozregression to find out what caused this regression. It'd be great to fix it with 65.
Somehow I think `toolbox.initInspector()` isn't called anymore before trying to highlight from the console. I think it used to be, and that's what is making this break now, because without it, the code realizes that the highlighter isn't ready, and bails out.
Thanks for investigating Patrick
Priority: P3 → P2
Yulia, would you know what's happening now?
Flags: needinfo?(ystartsev)
Yes, i think i know what is happening. I will take a look.
Flags: needinfo?(ystartsev)
Pushed by ystartsev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ca5e911d32f
fix console highlighting and update test to fail if it doesnt; r=nchevobbe
https://hg.mozilla.org/mozilla-central/rev/5ca5e911d32f
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee: nobody → ystartsev
Flags: qe-verify+
I can reproduce this following str from comment 0 with Nightly 65.0a1 (2018-12-05). I can verify that this issue is fixed in Latest Beta 65.0b7 in Linux x86_64.

Build ID 	20181227144402
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

[bugday-20190102]
I have reproduced this bug with Nightly 65.0a1 (2018-12-04) in Windows 7, 64 bit. This bug's fix is verified with latest Beta 65.0b8!

Build ID 	20190103150357
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

[bugday-20190102]

This is verified as fixed in both Linux (comment 11) and Windows (comment 12). Marking accordingly.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.