Closed Bug 1512132 Opened 2 years ago Closed 2 years ago

Unable to open image in (Confluence) image preview

Categories

(Core :: DOM: Core & HTML, defect)

Unspecified
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1424076
Tracking Status
firefox63 --- affected
firefox64 --- affected
firefox65 --- affected

People

(Reporter: e.glaubauf, Unassigned)

References

()

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

1: Got to https://docs.arnoldrenderer.com/display/A5AFMUG/Arnold+for+Maya+User+Guide 
2: Click on the Image 
3: The JS Loading cycles infinetly and the image does not load


Actual results:

- The JS Loading cycles infinetly and the image does not load
- You can not ESC from the Loading Screen 
- You have to close the tab or reload the page
- Chrome/Edge/Safari works fine
- This Problem occurs on different computers
- This problem can be reproduced on the entire domain




Expected results:

Load the Image (Gallery)
Hello,

I've managed to reproduce this issue on Win 10 and Mac OS 10.14 using Firefox 63.0.3 / Firefox Beta 64.0 / Firefox Nightly 65.0a1

I will add a component so that the developers can take a look at it.

Thank you for reporting!
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Version: 63 Branch → Trunk
I got a console error "TypeError: d is undefined[Learn More] batch.js:1575:7885" Could this be relevant?

I wonder if this is a recent regression. Do you recall an older version that works well without this issue, dear reporter?
Flags: needinfo?(e.glaubauf)
Hey there. Unfortunately I do not recall a specific version to introduce this behavior.  I just stumbled upon this and thought i should report this issue. 
Best, 
E
Flags: needinfo?(e.glaubauf)
The issue was reproducible on older versions, such as FF44. Given the console error, I'm wondering if this could be an issue on website. 
Hi Mike, could you help take a look? Thank you.
Flags: needinfo?(miket)
AFAICT, in https://docs.arnoldrenderer.com/s/ebb6e237105655ad9c258774877edbd3-CDN/en_GB/5995/0127276b0169dd26a3e4bad98655f37c1a27ef0f.306/fc23bc075fda87468abc55a8b45e0f8c/_/download/contextbatch/js/page,viewcontent,atl.general,main,pagebanner,atl.comments/batch.js?highlightactions=true&analytics-uploadable=true&flavour=VANILLA&nps-acknowledged=true&analytics-enabled=true&locale=en-GB&anonymous-access-enabled=true&is-server-instance=true&nps-enabled=true&hostenabled=true

d = Confluence.ScrollingInlineDialog(a, j, s, t)
and then later we hit that TypeError here:

setTimeout(function () {
  clearTimeout(q);
  var w = t;
  if (f(d[0]).is(':visible')) { <<<<<<<<<< d is undefined, so trying to access d[0] is blowing up
    w = r
  }
  q = setTimeout(function () {
    n()
  }, w)
}, r)

I'm stuck at https://github.com/devtools-html/debugger.html/issues/7485 when trying to debug this. Tom, can some of your tools get you any farther?
Flags: needinfo?(miket) → needinfo?(twisniewski)
Summary: Javascript Content not loading at all → Unable to open image in (Confluence) image preview

I see the same error in Chrome: Uncaught TypeError: Cannot read property '0' of undefined
So that's just a red herring.

However, I see two network requests (POSTS) being made by Firefox when I click on the image, both of them 404'ing, to:
https://docs.arnoldrenderer.com/rest/webResources/1.0/resources

In Chrome the first of those request isn't 404ing. That's because in Firefox there is no Origin header being sent, and it gets the response:
XSRF check failed

Sure enough, when I enable the about:config option network.http.sendOriginHeader, Firefox loads it fine.

So this is a dupe of bug 1424076, though we can reach out to ask the site to fall back on checking the Referer header if there is no Origin header.

Flags: needinfo?(twisniewski)

Harald, I hear you might have some outreach ties with Confluence? Might be worth pinging them to see if they're willing to use Referer if Origin isn't present, as per comment 6.

For now I'll dupe this against bug 1424076.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(hkirschner)
Resolution: --- → DUPLICATE
Duplicate of bug: 1424076

ni? myself to reach out to our contact at Confluence.

Flags: needinfo?(hkirschner) → needinfo?(miket)

(Oops, wrong bug)

I just tried to reproduce in Mana, which is Confluence server version 6.7.0, and it doesn't have the same bug.

(click on the space dog here: https://mana.mozilla.org/wiki/pages/viewpage.action?pageId=87367218)

This site is using Confluence version 5.8.15... so I'm not sure pinging Atlassian is worthwhile. The site really just needs to upgrade their version of Confluence from 5 to 6, which is probably non-trivial.

Flags: needinfo?(miket)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.