Headers from mail.compose.other.header should not autocomplete addresses

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: swaldman, Assigned: vparthas)

Tracking

({polish})

Trunk
x86
Linux
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052309

If a custom header is created using the mail.compose.other.header pref, then Moz
tries to autocomplete it as an email address.
As an example, if a header is created called X-No-Archive:, it's not possible to
simply enter "Yes", as this gets completed to "Yes@mylocaldomain.com".

This behaviour can be avoided by turning off address autocompletion, but that's
rather crippling... Could custom headers possibly have the same status as
Newsgroups:, ie not be considered email addresses? Or better still, make it an
option in the pref.

many thanks

Reproducible: Always
Steps to Reproduce:
1.n/a


Actual Results:  n/a

Expected Results:  n/a
good catch. Reassign to varada...
Assignee: ducarroz → varada
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Created attachment 87679 [details] [diff] [review]
Proposed patch

This patch uses a pref mail.compose.other.autocomplete which I assume needs to
be defaulted in some file somewhere...

Comment 3

17 years ago
Created attachment 87681 [details] [diff] [review]
Basic version (always disables autocomplete)

Updated

17 years ago
Keywords: patch, polish, review, ui

Comment 4

16 years ago
Looks like someone checked this in as part of another patch.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
Bug 16925 contains the patch that incorporated this fix.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.