Should not allow video-without-audio-track to autoplay when pref "media.autoplay.allow-muted=false"

RESOLVED FIXED in Firefox 66

Status

()

defect
P3
normal
RESOLVED FIXED
8 months ago
6 months ago

People

(Reporter: lh.bennett, Assigned: alwu)

Tracking

(Blocks 1 bug)

Trunk
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 wontfix, firefox66 fixed)

Details

(Whiteboard: [66b-qatriage-p2], )

Attachments

(1 attachment)

1. Set media.autoplay.allow-muted;false

2. Visit any Gizmodo Family Website.

3. Revoke Permission "Autoplay Media With Sound".

3. Scroll to a Gizmodo video entry.

The video plays regardless of the setting.
Matthew, can you triage this?
Flags: needinfo?(kinetik)
While trying to repro this, I wasn't served any autoplaying video content when I tried scrolling through gizmodo.com.au's front page until I hit the "end" (page 5 shown in the location bar, a button to load more content appears).

Visiting jalopnik.com, I'm shown a video under "Recent Videos" that begins autoplaying only if I scroll it out of view and back into view.  If I also toggle media.autoplay.enabled.user-gestures-needed to false, it never starts autoplaying.  It seems unexpected that scrolling would be considered a user intention to allow the video to play, but I'm not familiar with the autoplay blocking policy.  I'll needinfo Alastor to get his input.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kinetik) → needinfo?(alwu)
Priority: -- → P3
This issue is because we didn't check the pref "media.autoplay.allow-muted" when decide whether video without audio track can autoplay.
Assignee: nobody → alwu
Flags: needinfo?(alwu)
Summary: Jw Player bypasses autoplay permission → Should not allow video-without-audio-track to autoplay when pref "media.autoplay.allow-muted=false"
When talking about autoplay, video without audio track should also be controlled by the pref "media.autoplay.allow-muted".
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc450ef62331
hook pref "media.autoplay.allow-muted" to all inaudible autoplay media policy r=cpearce
https://hg.mozilla.org/mozilla-central/rev/dc450ef62331
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Whiteboard: [66b-qatriage-p2]
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.