Closed Bug 1512516 Opened 11 months ago Closed 10 months ago

Intermittent browser/components/search/test/browser/browser_searchTelemetry.js | Uncaught exception - undefined - timed out after 50 tries.

Categories

(Firefox :: Search, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 66
Tracking Status
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: standard8)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell disable-recommended])

Attachments

(1 file)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=215798043&repo=autoland

https://queue.taskcluster.net/v1/task/WU1lsuClSBaWPrGyrlPc4g/runs/0/artifacts/public/logs/live_backing.log

[task 2018-12-06T19:38:43.169Z] 19:38:43     INFO - TEST-START | browser/components/search/test/browser/browser_searchTelemetry.js
[task 2018-12-06T19:38:43.193Z] 19:38:43     INFO - GECKO(3024) | ++DOCSHELL 0x7f0145779000 == 4 [pid = 3241] [id = {51d9524b-ca01-4e57-829e-eedfdba1a79a}]
[task 2018-12-06T19:38:43.195Z] 19:38:43     INFO - GECKO(3024) | ++DOMWINDOW == 9 (0x7f01457a9000) [pid = 3241] [serial = 23] [outer = (nil)]
[task 2018-12-06T19:38:43.281Z] 19:38:43     INFO - GECKO(3024) | ++DOMWINDOW == 10 (0x7f01457ad400) [pid = 3241] [serial = 24] [outer = 0x7f01457a9000]
[task 2018-12-06T19:38:43.305Z] 19:38:43     INFO - GECKO(3024) | [Child 3241, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 8166
[task 2018-12-06T19:38:43.834Z] 19:38:43     INFO - GECKO(3024) | --DOMWINDOW == 0 (0x7fa645b25800) [pid = 3268] [serial = 9] [outer = (nil)] [url = about:blank]
[task 2018-12-06T19:38:43.844Z] 19:38:43     INFO - GECKO(3024) | ++DOMWINDOW == 11 (0x7f0147517000) [pid = 3241] [serial = 25] [outer = 0x7f01457a9000]
[task 2018-12-06T19:38:43.908Z] 19:38:43     INFO - GECKO(3024) | *** SearchTelemetry: SearchTelemetry::recordSearchURLTelemetry: example.in-content:sap:ff for http://mochi.test:8888/browser/browser/components/search/test/browser/searchTelemetry.html?s=test&abc=ff
[task 2018-12-06T19:38:44.035Z] 19:38:44     INFO - GECKO(3024) | "
[task 2018-12-06T19:38:51.916Z] 19:38:51     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/browser/components/search/test/browser/searchTelemetry.html?s=test&abc=ff&a=foo" line: 0}]
[task 2018-12-06T19:38:51.917Z] 19:38:51     INFO - TEST-PASS | browser/components/search/test/browser/browser_searchTelemetry.js | Should only have one key - 2 == 2 - 
[task 2018-12-06T19:38:51.922Z] 19:38:51     INFO - TEST-PASS | browser/components/search/test/browser/browser_searchTelemetry.js | Histogram should have the expected key: example.in-content:sap:ff - true == true - 
[task 2018-12-06T19:38:51.923Z] 19:38:51     INFO - TEST-PASS | browser/components/search/test/browser/browser_searchTelemetry.js | Should have counted the correct number of visits for example.in-content:sap:ff - 1 == 1 - 
[task 2018-12-06T19:38:51.925Z] 19:38:51     INFO - TEST-PASS | browser/components/search/test/browser/browser_searchTelemetry.js | Histogram should have the expected key: example.in-content:sap-follow-on:ff - true == true - 
[task 2018-12-06T19:38:51.926Z] 19:38:51     INFO - TEST-PASS | browser/components/search/test/browser/browser_searchTelemetry.js | Should have counted the correct number of visits for example.in-content:sap-follow-on:ff - 1 == 1 - 
[task 2018-12-06T19:38:51.928Z] 19:38:51     INFO - TEST-PASS | browser/components/search/test/browser/browser_searchTelemetry.js | Should have matched browser.search.with_ads in scalars and expectedScalars - false == false - 
[task 2018-12-06T19:38:51.929Z] 19:38:51     INFO - TEST-PASS | browser/components/search/test/browser/browser_searchTelemetry.js | Should have matched browser.search.ad_clicks in scalars and expectedScalars - false == false - 
[task 2018-12-06T19:38:51.932Z] 19:38:51     INFO - Leaving test bound test_follow_on_visit
[task 2018-12-06T19:38:51.933Z] 19:38:51     INFO - Entering test bound test_track_ad
[task 2018-12-06T19:38:51.935Z] 19:38:51     INFO - Console message: SearchTelemetry::recordSearchURLTelemetry: example.in-content:sap:ff for http://mochi.test:8888/browser/browser/components/search/test/browser/searchTelemetryAd.html?s=test&abc=ff
[task 2018-12-06T19:38:51.936Z] 19:38:51     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/browser/components/search/test/browser/searchTelemetryAd.html?s=test&abc=ff" line: 0}]
[task 2018-12-06T19:38:51.938Z] 19:38:51     INFO - Buffered messages logged at 19:38:46
[task 2018-12-06T19:38:51.939Z] 19:38:51     INFO - Console message: batchTask: Invalidating engine cache
[task 2018-12-06T19:38:51.940Z] 19:38:51     INFO - Console message: _buildCache: Writing to cache file.
[task 2018-12-06T19:38:51.942Z] 19:38:51     INFO - Buffered messages finished
[task 2018-12-06T19:38:51.943Z] 19:38:51     INFO - TEST-UNEXPECTED-FAIL | browser/components/search/test/browser/browser_searchTelemetry.js | Uncaught exception - undefined - timed out after 50 tries.
[task 2018-12-06T19:38:51.944Z] 19:38:51     INFO - Leaving test bound test_track_ad
[task 2018-12-06T19:38:51.945Z] 19:38:51     INFO - Entering test bound test_track_ad_new_window
[task 2018-12-06T19:38:51.946Z] 19:38:51     INFO - GECKO(3024) | ++DOCSHELL 0x7fbf9c1a7000 == 8 [pid = 3024] [id = {556a45d6-816c-457a-ad38-4623d749261c}]
[task 2018-12-06T19:38:51.947Z] 19:38:51     INFO - GECKO(3024) | ++DOMWINDOW == 21 (0x7fbf9a8b8c00) [pid = 3024] [serial = 34] [outer = (nil)]
[task 2018-12-06T19:38:51.948Z] 19:38:51     INFO - GECKO(3024) | ++DOMWINDOW == 22 (0x7fbf9a8b9400) [pid = 3024] [serial = 35] [outer = 0x7fbf9a8b8c00]
[task 2018-12-06T19:38:51.949Z] 19:38:51     INFO - GECKO(3024) | [Parent 3024, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 8166
[task 2018-12-06T19:38:51.951Z] 19:38:51     INFO - GECKO(3024) | [Parent 3024, Main Thread] WARNING: Attempting to get a displayport from a content with no primary frame!: file /builds/worker/workspace/build/src/layout/base/nsLayoutUtils.cpp, line 752
[task 2018-12-06T19:38:51.952Z] 19:38:51     INFO - GECKO(3024) | [Parent 3024, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 8166
[task 2018-12-06T19:38:51.953Z] 19:38:51     INFO - GECKO(3024) | [Parent 3024, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805D0021: file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 1010
[task 2018-12-06T19:38:51.954Z] 19:38:51     INFO - GECKO(3024) | ++DOCSHELL 0x7fbf9c1b7800 == 9 [pid = 3024] [id = {481898b9-210f-4a5f-a87b-fa7f4b3067ee}]
[task 2018-12-06T19:38:51.954Z] 19:38:51     INFO - GECKO(3024) | ++DOMWINDOW == 23 (0x7fbf9cfd4400) [pid = 3024] [serial = 36] [outer = (nil)]
[task 2018-12-06T19:38:52.012Z] 19:38:52     INFO - GECKO(3024) | ++DOCSHELL 0x7fe2c03d0000 == 1 [pid = 3130] [id = {77d63ddc-4dbe-4c0f-bacd-da667c663e5d}]
[task 2018-12-06T19:38:52.013Z] 19:38:52     INFO - GECKO(3024) | ++DOMWINDOW == 4 (0x7fe2c1ebe800) [pid = 3130] [serial = 39] [outer = (nil)]
This seems to be caused by Bug 1505411, Mark, can you take a look?
Flags: needinfo?(standard8)
Assignee: nobody → standard8
Flags: needinfo?(standard8)
Priority: P5 → P1
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b3f86194b14
Fix intermittent failure in browser_searchTelemetry.js by waiting for idle a few times so that the messages have chance to get to the actors. r=mak
https://hg.mozilla.org/mozilla-central/rev/5b3f86194b14
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.