Closed Bug 1512599 Opened 2 years ago Closed 1 year ago

[Youtube] Going back to an original video that was minimized (minivideo) will not display from top page

Categories

(Web Compatibility :: Desktop, defect, P1)

defect

Tracking

(firefox63 affected, firefox64 affected, firefox65 affected, firefox68 affected)

RESOLVED WONTFIX
Tracking Status
firefox63 --- affected
firefox64 --- affected
firefox65 --- affected
firefox68 --- affected

People

(Reporter: bogdan_maris, Unassigned)

References

()

Details

(Keywords: webcompat:site-wait)

Attachments

(1 file)

[Affected versions]:
- RC 64.0-build3
- DevEdition 65.0b2-build1 
- Latest Nightly 65.0a1

[Affected platforms]:
- macOS 10.13
- Windows 7 32bit
- Ubuntu 18.04 64bit

[Steps to reproduce]:
1. Start Firefox
2. Open any youtube video
3. Scroll in the page so a part of the video is hidden
4. Click the minivideo button inside the video
5. Click the minivideo video so it will get maximized

[Expected result]:
- When maximized, user has the top of the page displayed.

[Actual result]:
- Portion of the top video is cut off, the page is maximized but scrolled.

[Regression range]:
- Not a regression since most certainly this is something from youtube side. (60 nightly was also affected).

[Additional notes]:
- Chrome does not have this issue, when maximizing page, it will be always displayed from the top.
Product: Tech Evangelism → Web Compatibility

Tom, can you take a look? Chrome does scroll the document so the video is displayed (though not entirely to the top?) while Firefox doesn't.

Flags: needinfo?(twisniewski)
Priority: -- → P1

It doesn't seem as though they bother to change the scroll position at all in Firefox. The video is just shifted back into place, but the scroll position is kept as-is (no matter how far down the page I scroll before clicking the mini-video).

Unfortunately, I can't tell what's causing the scrolling in Chrome. It doesn't seem to be setting Element.prototype.scrollTop or calling Element.scrollIntoView or window.scroll/scrollTo/scrollBy. It's also not using the new picture-in-picture APIs.

I think we might just have to contact Google to get more insight here.

Flags: needinfo?(twisniewski) → needinfo?(miket)

Thanks Tom. I sent an email to our YT partner mailing list.

Flags: needinfo?(miket)

According to YouTube's response, they actually want Firefox's behavior in this case; that is, to retain your scroll position, not jump to the top. They don't seem to feel they can make it work 100% reliably, though. Based on that we might as well close this as a WONTFIX, since it's intended (or at least expected) behavior.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.