Closed Bug 15126 Opened 21 years ago Closed 21 years ago

accesskey not working for submenus on Windows

Categories

(Core :: XUL, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: hangas, Assigned: cmanske)

References

Details

(Whiteboard: verification blocked until 18294 is fixed.)

Submenus of the Windows XP menus are not supporting the accesskey settings.  The
underline does not show up and the accesskey does not work.
Blocks: 15096
Blocks: 15097
QA Contact: beppe → cpratt
Status: NEW → ASSIGNED
Target Milestone: M12
Assignee: saari → cmanske
Status: ASSIGNED → NEW
The cause of this is using "accessKey" instead of "accesskey".
I'll fix it as part of other work in navigatorOverlay.xul and global overlay
XUL files.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
QA Contact: cpratt → elig
QA Assigning to self for verification.
hangas, would you like to verify this bug, or provide a test case (or hint
towards how to create a test case)?

(I could easily check the document in question for cmanske's change, but would
prefer to see confirmation that the app is in fact doing the right thing, too.)

Thanks!
One month ago this was working for me.  Currently, I am not able to verify or
provide a test case because I am seeing failures of accesskey in any/all menu
items.  No way to be sure if the sub-menus work since I cannot get the outermost
ones to work.
Depends on: 18294
Thanks. So, it sounds like the verification of this bug is dependent upon 18294
being fixed. [Adding to dependency list; please insert your $.02 if this
conclusion is erroneous.]

Thanks!
Whiteboard: verification blocked until 18294 is fixed.
QA Contact: elig → sairuh
[Menu bug; QA Assigning to Sarah.]
Status: RESOLVED → VERIFIED
verified as fix on winNT using comm bits from 2000011408.
You need to log in before you can comment on or make changes to this bug.