Closed Bug 1512650 Opened 3 years ago Closed 3 years ago

Allow overriding actions like Switch to tab

Categories

(Firefox :: Address Bar, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: mak, Assigned: dao)

References

(Regressed 1 open bug)

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

The awesomebar allows to override a switch to tab action using SHIFT, we should support that. It's also a visual change since the match and the input field react to shift being pressed on a switch to tab match.
Depends on: 1515285

Existing tests for this: browser_bug1003461-switchtab-override.js, browser_bug1024133-switchtab-override-keynav.js

Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: P2 → P1
Blocks: 1512653
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/987910383af0
Allow overriding actions like Switch to tab. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Blocks: 1524838
Regressions: 1670484
You need to log in before you can comment on or make changes to this bug.