Properly display and support selecting search matches

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P2
normal
RESOLVED FIXED
7 months ago
6 months ago

People

(Reporter: mak, Assigned: standard8)

Tracking

(Blocks 1 bug)

Trunk
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 wontfix, firefox66 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Search matches don't have a url, so when the user confirms them nothing happens.
We should use the search service to build and visit a proper search url.
Assignee: nobody → standard8
Status: NEW → ASSIGNED

As part of the work I'm doing on this, I'm also fixing up display of the search entries themselves in the view - as it makes it easier for manual testing - clarifying subject to make that clearer.

Summary: Properly support selecting search matches → Properly display and support selecting search matches
Depends on: 1520336
This implements the correct display of search matches, except for the fact that the "Search with" text should not be shown by default only on hover.

The actual selection of the result should work the same as for the quantum bar, and have the same telemetry hooked up.

Depends on D16617
Duplicate of this bug: 1512670
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/96880bb35099
Properly display search matches and make them functional on the new QuantumBar. r=dao
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Blocks: 1512652
You need to log in before you can comment on or make changes to this bug.