Address bar URL failure causes search drop-down to fail

VERIFIED DUPLICATE of bug 147667

Status

SeaMonkey
UI Design
--
minor
VERIFIED DUPLICATE of bug 147667
16 years ago
14 years ago

People

(Reporter: Jeff Wofford, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I make this mistake a lot. The mistake is mine, but it highlights a bug which isn't.

After entering an invalid URL in the address bar, the down-arrow key appears to
higlight the search entry for the address bar text but does not actually select
the search. I'm making no sense, am I? Read the Steps to Reproduce.

Reproducible: Always
Steps to Reproduce:
1. Enter a series of keywords in the address bar (e.g. "dog cat rabbit" without
the quotes), intending to use the Search Service on these keywords (I use Google).
2. Forget to hit the down arrow on the keyboard or click the Search button.
Instead, just hit enter.
3. Mozilla tells you that your URL be whack. 
4. Think "Oops! Meant to search for that."
5. Click OK to close the dialog box.
6. Select the Address Bar again by clicking it.
7. Push the down arrow, thus producing the Address Bar's dropdown list.
8. Push the down arrow again, thus highlighting the drop-down list item
corresponding to the keyword search.
9. Hit Enter.

Actual Results:  Mozilla ignores the drop-down list and instead runs the address
bar contents as a URL fetch. It again tells you your URL be whack.

Expected Results:  Used your preferred search service to search for the keywords.

The workaround is to click the "Search" button. Not that big a deal, but like
many people I don't like to jump between the mouse and keyboard. Once my hands
are on the keyboard, they like to stay there. Anyway, it's a bug so quit whining
and get to work.

Comment 1

16 years ago
*** Bug 151283 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 147667 ***
URL: any
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.