crash closing download manager while downloading if is last window

VERIFIED WORKSFORME

Status

SeaMonkey
Download & File Handling
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Devoti Paolo, Assigned: Blake Ross)

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020609
BuildID:    2002060908

Reproducible: Always
Steps to Reproduce:
1.start downloading something
2.close all mozilla windows 
3.close download manager while download is still in progress

Actual Results:  crash

Expected Results:  download aborted or a dialog asking a confirm

Comment 1

16 years ago
Reporter, do you get a Talkback window when crashing ? If so, please post
Talkback ID for this crash by running 'mozilla\bin\components\talkback.exe'.
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
Talkback ID TB7277502W

Comment 3

16 years ago
Didn't find dupes (besides bug 132905 ?), marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: Need TB7277502W data
talkback info...

KERNEL32.DLL + 0xa128 (0xbff7a128)
MSVCRT.DLL + 0x113d (0x7800113d)
MSVCRT.DLL + 0x1f5f (0x78001f5f)
InMemoryDataSource::~InMemoryDataSource [nsInMemoryDataSource.cpp, line 928]
InMemoryDataSource::`scalar deleting destructor'
InMemoryDataSource::Internal::Release [nsInMemoryDataSource.cpp, line 966]
InMemoryDataSource::Release [nsInMemoryDataSource.cpp, line 962]
InternetSearchDataSource::~InternetSearchDataSource
[nsInternetSearchService.cpp, line 560]
InternetSearchDataSource::`scalar deleting destructor'
InternetSearchDataSource::Release [nsInternetSearchService.cpp, line 887]
nsCOMPtr_base::assign_with_AddRef [nsCOMPtr.cpp, line 74]
nsComponentManagerImpl::FreeServices [nsComponentManager.cpp, line 1894]
0x80000000
0x0071d6b4
Keywords: stackwanted
Whiteboard: Need TB7277502W data

Comment 5

16 years ago
could this be related to bug 149389 or bug 148852 ?
not sure since i think this was reported with a mozilla build, not a commercial
one. those other bugs seem to deal mostly with aim/icq issues...

Comment 7

15 years ago
Marking this WFM since this isn't occuring in the 2002-10-09-08 trunk build.
Tested under Windows ME.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.