All users were logged out of Bugzilla on October 13th, 2018

Moving multiple Messages to different folder (may) hang

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: j.ole1, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

Dragging and dropping multiple messages to different folders (including deleting
them with the del key) sometimes hangs, reproducibly on some messages, randomly
on others, most often when moving them from a mailbox in a subfolder of an
account to one in that accounts root folder. Reproducible (most of the time)
when moving multiple messages back and forth between mail boxes.

Has been there in most (or maybe all, I cannot verify that) nightlies after the
release of Mozilla 1.0. Doesn't happen with 1.0 (and earlier releases).

Doesn't hang the program or crash it. I can even still highlight the affected
mails - they just don't get moved. Sometimes some of the selected mails appear
in the destination folder (the complete messages, not just parts of them).

Reproducible: Sometimes
Steps to Reproduce:
1. Highlight several messages in a folder
2. Drag them to another folder
3. (If it doesn't "not work", try again, reverse order)


Actual Results:  Messages didn't disappear from their original folder, progress
bar kept "rolling" and saying "Moving message one of three" (for example).

Expected Results:  Moved messages.

Comment 1

17 years ago
*** Bug 151282 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
Confirming on 2002061108 Win2k.

BTW, bug 151137 may be related.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Severity: normal → major

Comment 3

17 years ago
I get same results on that build, win2k. If you shut down Mozilla entirely and
reopen mail/news, one message does get moved.

Updated

17 years ago
Blocks: 151531
WFM 2002061404 Win2k

Suspect this was fixed with bug 150716
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
marking verified worksforme
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.