Open Bug 1512802 Opened 10 months ago Updated 11 days ago

Consider allowing individual session management of containers

Categories

(Firefox :: Session Restore, enhancement, P4)

63 Branch
enhancement

Tracking

()

REOPENED

People

(Reporter: fynx.gloire, Unassigned, NeedInfo)

References

(Depends on 2 open bugs, Blocks 4 open bugs, )

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

Hello, I just downloaded Firefox and installed the Firefox Multi Account Containers plugin. What I like to do is to have a way to SAVE all my tabs within a session. The session I saved it to should support the multi account containers. ex. I save 2 different gmail account tabs and 3 different twitter account tabs. When I want to restore them they open up 5 different tabs, 2 with my 2 separate gmail accounts logged in and 3 other twitter tabs with the different accounts logged into that.

Is it currently possible, I have not found anything yet.

Regards



Actual results:

does not restore my sessions using Restore all of my tabs in separate sessions using the multi account container


Expected results:

Restore all of my tabs in separate sessions using the multi account container
Component: Untriaged → General
Product: Firefox → WebExtensions
I'm a little unclear on the #c0. Are you saying that you want the ability to:

a) save sessions manually, and have them include containers?
b) have a restored session include containers?

The differentiation is whether this is a request for session saving, or a request for container use to persist in session restoration.

I think what's confusing me is the sentence: "does not restore my sessions using Restore all of my tabs in separate sessions using the multi account container" -- it's not informative to describe what does not occur, but rather to describe what does occur.
Flags: needinfo?(fynx.gloire)

Closing due to lack of feedback. Please re-open if this is still an issue.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → INCOMPLETE
Blocks: ss-feature

The main focus is about getting Firefox ability (basic using build-in Session Restore or more advanced using session manager extensions):

(1) to save automatically/manually sessions with information about tabs, windows and containers they are located in (including account log in information),
(2) to restore automatically/manually session with containers/windows/tabs,
(3) to save manually single container as session,
(4) to add manually tabs from session with 1 or more container(s) to existing session with its own container(s); added container(s) could be the same like in existing session (with the same account logins), or different,
(3') to save manually single Firefox window as session, and
(4') to add manually tabs from session with 1 or more Firefox window(s) to existing session with its own window(s).

Build-in Session Restore could provide more basic support for containers/windows - points (1) and (2).
And session manager extensions could deliver more advanced options: (1), (2), (3) and (4). New session management API will be written soon (I hope), so it is good time to include this in session management API design (Bug 1427928).

Terrific idea.
In my case I would like an option for automatically saved sessions with containers information.

I'd very much like a (native) way to approach contextual identity containers as browser sessions themselves. The current browser session save/restore functionality is very rigid, since it only handles the full session or nothing.

I think it makes a lot of sense to at least implement points 1 and 2 natively into the browser because contextual identities are a quasi-native feature. At least it's promoted that way (https://support.mozilla.org/en-US/kb/containers).

Context:
I use FF as my daily driver and use containers to effectively seperate different workflows; social media, open-source development and learning Haskell, for example. These three container sessions are parts of my browser session.
Thanks to the session restore feature I can exit FF and have the entire session open again on next start, basically a workspace.
Interaction issues arise when I start FF with a specific intent, like doing a quick google search. The intent is clear on which container(s) I actually want to use, but the browser only supports restoring the entire session. Having the option to select earlier sessions, keyed on used containers would help tremendously.

There are alternative approaches, like having different profiles, using extensions or "simply don't close the browser" to achieve the desired behavior. They sadly don't intuitively support the example usage, if at all. I need to close my browser in certain situations due to ram availability or generally for the small performance boost when playing games.

To conclude:
By any means, I'm not claiming to be a UX expert but it's time to show competitors that the FF contextual identities, (automatic) session management functionality and a good/intuïtive interface on top enables a coveted, flexible browsing experience.

(In reply to David Durst [:ddurst] from comment #2)

Closing due to lack of feedback. Please re-open if this is still an issue.

I am re-opening this bug.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---

I don't know if Robert Ab is speaking for the reporter, but I think I get the intention here: the desire is to be able to save and restore containers as if they are discrete sessions. That has to exist first before this can be something for extensions to use.

Re-summarizing and reclassifying accordingly. Also linking this as an issue in the Multi-Account Containers repo: https://github.com/mozilla/multi-account-containers/issues

Severity: normal → enhancement
Component: General → Session Restore
Product: WebExtensions → Firefox
Summary: Saving Firefox Multi Account Container sessions → Consider allowing individual session management of containers

Consider supporting save/restore of individual containers within/from a session (GitHub):
https://github.com/mozilla/multi-account-containers/issues/1325

David: Thank you for reporting this issue on GitHub

Blocks: ss-SM
See Also: → 1298912
Blocks: 1232178
See Also: → 1357214
See Also: → 1332447
Depends on: 1298912
See Also: 1298912
See Also: → mult_sessions2
See Also: → 1524959

Alternative to this bug (Bug 1512802) is shown in Bug 1524959 (Bug 1524959), which is an extension of bigger proposal described in two alternative bugs:

See Also: → mult_sessions1
See Also: 1332447

(In reply to Robert Ab from comment #9)

Alternative to this bug (Bug 1512802) is shown in Bug 1524959 (Bug 1524959), which is an extension of bigger proposal described in two alternative bugs:

For heaven's sake. So much friggin bugzilla spam for a lost cause. Mozilla never implements ideas coming from the outside.
FF doesn't even support session management by addons anymore, despite of much begging.

Depends on: 1524959

(In reply to avada from comment #10)

FF doesn't even support session management by addons anymore, despite of much begging.

Currently, Session Restore is rewritten - check Bug 1474130 and its dependency tree:
https://bugzilla.mozilla.org/showdependencytree.cgi?id=1474130&hide_resolved=0
This work needs to be completed before session management API (Bug 1427928) can be prepared.

Priority: -- → P4
You need to log in before you can comment on or make changes to this bug.