Closed Bug 1512979 Opened 4 years ago Closed 4 years ago

"word-break: break-all" on an inline-level element doesn't reduce the min-content size of ancestors (but it should)

Categories

(Core :: Layout: Block and Inline, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1507744
Tracking Status
firefox65 --- affected

People

(Reporter: dholbert, Unassigned)

References

Details

(Whiteboard: [webcompat])

Attachments

(3 files)

STR:
 1. Load attached testcase.

EXPECTED RESULTS:
The "aaaaa" text should be wrapped, with 1 character per line.

ACTUAL RESULTS:
The "aaaaa" text isn't wrapped.

Chrome gives EXPECTED RESULTS.
Firefox gives ACTUAL RESULTS (broken), though I can fix it if I put the word-break styling on a block-level element (either by making the span `display:block`, or by moving the word-break styling up one level to be on the testcase's existing block).


This issue is implicated in webcompat issue https://github.com/webcompat/web-bugs/issues/22348 (broken layout on github, with long repository names)
Attached file testcase 1
Attachment #9030230 - Attachment description: reference case 1b: give the block "word-break: break-all" → reference case 1b: put "word-break: break-all" on the block (not just on the span)
(In reply to Daniel Holbert [:dholbert] from comment #0)
> Firefox gives ACTUAL RESULTS (broken), though I can fix it if I put the
> word-break styling on a block-level element (either by making the span
> `display:block`, or by moving the word-break styling up one level to be on
> the testcase's existing block).

The just-attached reference cases demonstrate these workarounds.  (It doesn't make sense to me that either reference case's tweak should influence the testcase's rendering, so I think they demonstrate that this inconsistency is a bug.)
Summary: "word-break: break-all" doesn't reduce the min-content size of ancestors (but it should) → "word-break: break-all" on an inline-level element doesn't reduce the min-content size of ancestors (but it should)
That webcompat.com thing is exactly what made me file bug 1507744.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1507744
You need to log in before you can comment on or make changes to this bug.