Text in menus is incorrectly centered.

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
6 months ago
6 months ago

People

(Reporter: ewright, Assigned: Matthias)

Tracking

({regression})

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 verified, firefox66 verified)

Details

Attachments

(2 attachments)

Reporter

Description

6 months ago
The styles that were changed to update the button spec also affected the menu inputs.

STR:
- go to about:preferences
- under "fonts and colors" click to open the menu

AR:
- each menu item is centered

ER:
- The menu items are left-aligned in LTR and right-aligned in RTL


I believe this is due to this rule https://searchfox.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#177
Assignee

Comment 2

6 months ago
I tested to remove the "text-align" line.
This did the trick and the buttons are still centered.
Priority: -- → P1
Assignee

Updated

6 months ago
Assignee: nobody → matthias
Status: NEW → ASSIGNED
Attachment #9030360 - Attachment description: Bug 1513035 - Resolved incorrect centering for menus. r=ewright → Bug 1513035 - Remove text-align: center; from common.css buttons r=ewright, dao

Comment 4

6 months ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b976d3cfa074
Remove text-align: center; from common.css buttons r=ewright,dao

Comment 5

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b976d3cfa074
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
This will need to be uplifted.

Comment 7

6 months ago
Comment on attachment 9030360 [details]
Bug 1513035 - Remove text-align: center; from common.css buttons r=ewright, dao

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1511394

User impact if declined: See comment 0 & comment 1

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: See comment 0 & comment 1

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): one line CSS removal

String changes made/needed:
Attachment #9030360 - Flags: approval-mozilla-beta?
I successfully reproduced the issue on Firefox Nightly 65.0a1 (2018-12-10) under Windows 10 (x64) using STR from Comment 0.

The issue is no longer reproducible on latest Nightly 66.0a1 (2018-12-12) under Windows 10 (x64), macOS 10.12 and Ubuntu 16.04 (x64).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Comment on attachment 9030360 [details]
Bug 1513035 - Remove text-align: center; from common.css buttons r=ewright, dao

[Triage Comment]
Minor CSS tweak, approved for 65.0b5.
Attachment #9030360 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
The issue is verified fixed on Firefox 65.0b5 (20181216183345). Tests were performed under Windows 10 (x64), macOS 10.12 and Ubuntu 16.04 (x86).
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.