Remove doorhanger related codes

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P2
normal
RESOLVED FIXED
6 months ago
5 months ago

People

(Reporter: alwu, Assigned: alwu)

Tracking

(Depends on 2 bugs, Blocks 1 bug)

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(14 attachments, 1 obsolete attachment)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
Assignee

Description

6 months ago
From the result of shield-study, user seems not really like doorhanger, so we've decided to remove it and use block-by-default as a default option.
Assignee

Updated

6 months ago
Priority: -- → P2
Assignee

Updated

6 months ago
Blocks: 1513681
Assignee

Comment 1

6 months ago
We would remove all temporary permission related codes, so we don't need to cache it anymore.
Assignee

Comment 5

6 months ago
Wrap 'nsContentUtils::ReportToConsole()' to reduce neccesary input parameters and call it when we
need to log error or warning message. Show the warning when autoplay is blocked.

Depends on D14329
Assignee

Comment 7

6 months ago
Remove doorhanger related codes, check whether web audio starts when calling calling resume() or
AudioScheduledNode.start() after granting user activation.

Depends on D14331
Assignee

Comment 9

6 months ago
We would show checkbox no matter whether user changes prefs or not.

Depends on D14333
Assignee

Comment 10

6 months ago
Depends on D14334
Assignee

Comment 12

6 months ago
As we has removed prompt, we should find other way to show the block icon and uncomment test.
Will implement it in bug1513681.

Depends on D14336
Assignee

Comment 13

6 months ago
After removing autoplay doorhanger, we won't have temporary allow.
Assignee

Updated

6 months ago
Duplicate of this bug: 1513612
Attachment #9030909 - Attachment description: Bug 1513039 - part7 : modify web audio test. → Bug 1513039 - part7 : modify web audio autoplay test for removal of doorhanger
Attachment #9030906 - Attachment description: Bug 1513039 - part4 : remove permission request codes in AudioContext. → Bug 1513039 - part4 : remove permission request code in AudioContext.
Attachment #9030906 - Attachment description: Bug 1513039 - part4 : remove permission request code in AudioContext. → Bug 1513039 - part4 : remove permission request logic in AudioContext.
Assignee

Comment 15

6 months ago
'mWasAllowedToStart' would be set to flase if AudioContext is not allowed to start at the time of contruction, and
we should set it to true when AudioContext is allowed to start.
Attachment #9031605 - Attachment description: Bug 1513039 - part14 : set 'mWasAllowedToStart' flag when AudioContext is allowed to start → Bug 1513039 - part14 : set 'mWasAllowedToStart' flag.
Assignee

Updated

6 months ago
No longer blocks: 1513681
Depends on: 1513681
Duplicate of this bug: 1516582
Attachment #9030916 - Attachment is obsolete: true
Attachment #9030922 - Attachment description: Bug 1513039 - part13 : remove temporary allow. → Bug 1513039 - part12 : remove temporary allow.
Attachment #9031605 - Attachment description: Bug 1513039 - part14 : set 'mWasAllowedToStart' flag. → Bug 1513039 - part13 : set 'mWasAllowedToStart' flag.
Attachment #9031607 - Attachment description: Bug 1513039 - part15 : add new error message for web audio. → Bug 1513039 - part14 : add new error message for web audio.
Assignee

Updated

6 months ago
Duplicate of this bug: 1517284
Comment hidden (obsolete)

Comment 20

5 months ago
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/612d05e15b6f
part1 : remove caching temporary autoplay permission. r=smaug,florian
https://hg.mozilla.org/integration/autoland/rev/838615dbf1f3
part2 : remove temporary autoplay permission tests. r=florian
https://hg.mozilla.org/integration/autoland/rev/5d5121ecc181
part3 : remove permission request codes in MediaElement. r=cpearce
https://hg.mozilla.org/integration/autoland/rev/dba8b9714294
part4 : remove permission request logic in AudioContext. r=karlt
https://hg.mozilla.org/integration/autoland/rev/0e229bbdaae5
part5 : log warning when autoplay is blocked. r=cpearce,karlt
https://hg.mozilla.org/integration/autoland/rev/54817f010dde
part6 : remove AutoplayPermissionManager and AutoplayPermissionRequest. r=cpearce,smaug
https://hg.mozilla.org/integration/autoland/rev/1a70b4c3fc0e
part7 : modify web audio autoplay test for removal of doorhanger r=karlt
https://hg.mozilla.org/integration/autoland/rev/460739b43008
part8 : remove autoplay prompt front-end codes. r=florian,daleharvey,flod
https://hg.mozilla.org/integration/autoland/rev/cc8a4fd6fda0
part9 : remove autoplayMediaCombobox. r=daleharvey,flod
https://hg.mozilla.org/integration/autoland/rev/2e48b6769911
part10 : remove nsIAutoplay.PROMPT r=daleharvey,cpearce
https://hg.mozilla.org/integration/autoland/rev/df38df5ce11e
part11 : remove pref 'media.autoplay.ask-permission'. r=cpearce
https://hg.mozilla.org/integration/autoland/rev/b67708aaec68
part12 : remove temporary allow. r=daleharvey,florian
https://hg.mozilla.org/integration/autoland/rev/a06f5553f2ca
part13 : set 'mWasAllowedToStart' flag. r=karlt
https://hg.mozilla.org/integration/autoland/rev/14ee7539fbc0
part14 : add new error message for web audio. r=baku,flod
https://hg.mozilla.org/projects/cedar/rev/612d05e15b6f99c7f5efb688ea9513f21bfa5491
Bug 1513039 - part1 : remove caching temporary autoplay permission. r=smaug,florian

https://hg.mozilla.org/projects/cedar/rev/838615dbf1f307e1adc83c7152fcb22cc8584e4d
Bug 1513039 - part2 : remove temporary autoplay permission tests. r=florian

https://hg.mozilla.org/projects/cedar/rev/5d5121ecc18102123d5b84f388313a10a535e2dd
Bug 1513039 - part3 : remove permission request codes in MediaElement. r=cpearce

https://hg.mozilla.org/projects/cedar/rev/dba8b9714294f04b19675a10c972bdd72ab7f9ef
Bug 1513039 - part4 : remove permission request logic in AudioContext. r=karlt

https://hg.mozilla.org/projects/cedar/rev/0e229bbdaae5c8fa9f83796c628a4fdf88f057ba
Bug 1513039 - part5 : log warning when autoplay is blocked. r=cpearce,karlt

https://hg.mozilla.org/projects/cedar/rev/54817f010dde7ba75d4b506be0e55eac3a890471
Bug 1513039 - part6 : remove AutoplayPermissionManager and AutoplayPermissionRequest. r=cpearce,smaug

https://hg.mozilla.org/projects/cedar/rev/1a70b4c3fc0ec88667508ebb87deefc2923693a7
Bug 1513039 - part7 : modify web audio autoplay test for removal of doorhanger r=karlt

https://hg.mozilla.org/projects/cedar/rev/460739b430085464419cab4495a5c46cc77e15cc
Bug 1513039 - part8 : remove autoplay prompt front-end codes. r=florian,daleharvey,flod

https://hg.mozilla.org/projects/cedar/rev/cc8a4fd6fda06168b63b724d2215c615176e8f2a
Bug 1513039 - part9 : remove autoplayMediaCombobox. r=daleharvey,flod

https://hg.mozilla.org/projects/cedar/rev/2e48b6769911e46cd51387805c2722cf9b16ee9f
Bug 1513039 - part10 : remove nsIAutoplay.PROMPT r=daleharvey,cpearce

https://hg.mozilla.org/projects/cedar/rev/df38df5ce11e8d9736ec81eb9bf75fc1e35698d8
Bug 1513039 - part11 : remove pref 'media.autoplay.ask-permission'. r=cpearce

https://hg.mozilla.org/projects/cedar/rev/b67708aaec68b07ecc71c3a5cc7587b0b6dfe52b
Bug 1513039 - part12 : remove temporary allow. r=daleharvey,florian

https://hg.mozilla.org/projects/cedar/rev/a06f5553f2cafd6915f650a82a379018c5fdfdc6
Bug 1513039 - part13 : set 'mWasAllowedToStart' flag. r=karlt

https://hg.mozilla.org/projects/cedar/rev/14ee7539fbc0fb33d4616d38dcbf225894dec9c8
Bug 1513039 - part14 : add new error message for web audio. r=baku,flod
Depends on: 1520457
You need to log in before you can comment on or make changes to this bug.