Spellchecker defaults to Download More

VERIFIED DUPLICATE of bug 154680

Status

SeaMonkey
Composer
--
major
VERIFIED DUPLICATE of bug 154680
16 years ago
14 years ago

People

(Reporter: mkaply, Assigned: Charles Manske)

Tracking

({crash, intl})

Trunk
crash, intl

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I have verified this on OS/2 and on Beonex on Windows.

The spellchecker code in nsEditorShell.cpp tries to get the current 
locale using the chrome if no dictionary is set. This code is failing.

I have written new code that simply queries the 
general.useragent.locale from navigator.properties. This seems a little 
more elegant.
(Reporter)

Comment 1

16 years ago
Created attachment 87431 [details] [diff] [review]
Fix for problem

Just query the locale from navigator.properties
(Reporter)

Comment 2

16 years ago
I'm marking this adt1.0.1 so that Netscape will see it.

You will run into this problem with Netscape 7. The spellchecker will 
default to Download More instead of en-US.

Thought I would save you the trouble of finding and fixing it.
Keywords: adt1.0.1

Updated

16 years ago
Keywords: intl, nsbeta1

Comment 3

16 years ago
adding adt1.0.1- per adt.  Let's get this in the next release.
Keywords: adt1.0.1 → adt1.0.1-
(Reporter)

Comment 4

16 years ago
You do understand that what this means is that the spellchecker will appear not 
to work.

When you spellcheck, it will say "no misspelled words found" even though there 
are.

The user has to explicitly change dictionary and then recheck to get the 
spellchecker to work.
(Reporter)

Comment 5

16 years ago
This can also cause a crash if you open spellchecker and then click on Edit... 
without selecting a language for the dictionary first.
Keywords: crash
Clearing adt- for reconsideration.

reassigning to brade to triage since Syd is out for the week.
Assignee: syd → brade
Keywords: adt1.0.1- → adt1.0.1

Comment 7

16 years ago
Comment on attachment 87431 [details] [diff] [review]
Fix for problem

r=brade
Attachment #87431 - Flags: review+
(Reporter)

Comment 8

16 years ago
I don't understand how, but NS 7 seems to get the right dictionary on a new 
profile creation. Beats me.

It fails in a straight Mozilla build, and the spellchecker isn't be involved in 
finding the language dictionary.

Perhaps the code that checks for the locale works in an NS7 build, I don't know.

So I am going to take this off the NS7 radar - you have enough to do.
Keywords: adt1.0.1 → adt1.0.1-

Comment 9

16 years ago
-->cmanske since I'm going to be at MacHack
Assignee: brade → cmanske

Comment 10

16 years ago
ftang or msanz--can one of you speak to the importance of this bug?  Is it
something that should be addressed soon for upcoming releases?
(note: there is a patch attached)
(Reporter)

Comment 11

16 years ago
We found the core problem.

Regression in RFind.

*** This bug has been marked as a duplicate of 154680 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 12

16 years ago
bulk verification.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.