Closed Bug 15133 Opened 20 years ago Closed 20 years ago

scope relationship between select object and enclosing objects is bad

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: phil, Assigned: vidur)

References

()

Details

(Whiteboard: [TESTCASE])

Attachments

(1 file)

I happened to be surfing http://www.sel.sony.com/ and noticed that in 4.61,
there is flyover feedback on each of their product categories. In mozilla, we
don't get the flyover feedback. Not sure if this is really a JS engine bug, but
since they seem to be using JS to swap the images, I'll start with that
component
Assignee: mccabe → joki
Component: Javascript Engine → Event Handling
QA Contact: cbegle → janc
changing component to Event Handling
Whiteboard: [TESTCASE]
*** Bug 15910 has been marked as a duplicate of this bug. ***
Assignee: joki → vidur
Component: Event Handling → DOM Level 0
OS: Windows NT → All
Hardware: PC → All
Summary: Javascript onmouseover to change image not working → scope relationship between select object and enclosing objects is bad
I noticed Bug #15910 was a duplicate of this one but the report was much better
there (no way to tell this is the same issue with a description of "onMouseOver
problems"), so I'm stealing the summary line and some of the description from
there:

The JS engine is unable to find the reference to 'img1' (see testcase), but the
same works if 'img1' is rewritten as 'document.img1'.

This indicates that the nested scope relationship between the img object and its
outer objects are not properly initialized.

changing component and reassinging.
Actually, the scope relationships are set up correctly. The problem is that we
need a Resolve method on nsHTMLDocument so that the unqualified "img1" is
resolved correctly. The scope relationship can be confirmed by looking at the
__prototype__ properties of the elements up the chain.
*** Bug 15185 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed on 11/24/1999. See 19650 for more information about the fix.
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.