Closed Bug 1513300 Opened 9 months ago Closed 8 months ago

Add a cryptomining feature to the URL classifier

Categories

(Toolkit :: Safe Browsing, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: englehardt, Assigned: baku)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

We should add a feature to the URL classifier that consumes the cryptomining categorized list from shavar and cancels the channel.
Blocks: fpcmblocking
No longer blocks: 1511436
Depends on: 1511436
No longer depends on: fpcmblocking
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → amarchesini
Attachment #9031814 - Flags: review?(dlee)
Comment on attachment 9031814 [details] [diff] [review]
patch

This patch is built on top of the fingerprinting feature. I want to see that one reviewed before asking here a review.
Attachment #9031814 - Attachment is obsolete: true
Attachment #9031814 - Flags: review?(dlee)
Component: Tracking Protection → Safe Browsing
Product: Firefox → Toolkit
Status: NEW → ASSIGNED
Priority: -- → P1
Attachment #9034539 - Flags: review?(dlee)
Duplicate of this bug: 1403109

Comment on attachment 9034539 [details] [diff] [review]
feature_cryptomining.patch

Review of attachment 9034539 [details] [diff] [review]:

Looks good to me, please also check the comment in fingerprinting, thanks!

Attachment #9034539 - Flags: review?(dlee) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d503dc3fd033
Implement Cryptomining URL-Classifier, r=dimi
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.