Closed Bug 1513332 Opened 9 months ago Closed 8 months ago

Crash in mozilla::dom::CustomElementRegistry::CallGetCustomInterface

Categories

(Core :: XUL, defect, P1, critical)

Unspecified
Windows 8
defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: calixte, Assigned: enndeakin)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-1c216d5c-8801-4fd2-aed6-67c6c0181211.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::CustomElementRegistry::CallGetCustomInterface dom/base/CustomElementRegistry.cpp:1174
1 xul.dll static void mozilla::dom::Element::GetCustomInterface<nsIDOMXULSelectControlItemElement> dom/base/Element.cpp:3871
2 xul.dll mozilla::dom::Element::AsXULSelectControlItem dom/base/Element.cpp:4004
3 xul.dll mozilla::a11y::XULListboxAccessible::Value accessible/xul/XULListboxAccessible.cpp:114
4 xul.dll mozilla::a11y::AccessibleWrap::get_accValue accessible/windows/msaa/AccessibleWrap.cpp:374
5 rpcrt4.dll Invoke 
6 oleacc.dll oleacc.dll@0x13c45 
7 rpcrt4.dll NdrpFreeParams 
8 rpcrt4.dll RpcBindingInqObject 
9 combase.dll CStdAsyncStubBuffer2_Disconnect 

=============================================================

There are 3 crashes (from 3 installations) in nightly 66 starting with buildid 20181210220553. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1492326.

[1] https://hg.mozilla.org/mozilla-central/rev?node=f69b2af6280a
Flags: needinfo?(enndeakin)
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
Attachment #9030735 - Flags: review?(surkov.alexander)
Priority: -- → P1
Blocks: 1514687
This is preventing me from investigating bug 1514687.
Comment on attachment 9030735 [details] [diff] [review]
Add null checks in XULListboxAccessible

Stealing review from surkov since he is no longer working on accessibility full-time (but the module docs don't reflect this yet). r=me. Thanks!
Attachment #9030735 - Flags: review?(surkov.alexander) → review+
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/003adae62f33
add some null-pointer checks on elements in XULListboxAccessible, r=marcoz
Backout by dluca@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/303797fd3722
Backed out 2 changesets (bug 1513332, bug 1445942) for browser-chrome failures in browser/base/content/test/permissions/browser_reservedkey.js
Backed out 2 changesets (bug 1513332, bug 1445942) for browser-chrome failures in browser/base/content/test/permissions/browser_reservedkey.js

Log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=217538812&repo=mozilla-inbound&lineNumber=2569

13:28:34     INFO - Entering test bound test_reserved_shortcuts
13:28:34     INFO - Buffered messages logged at 13:27:06
13:28:34     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<body onload='document.body.firstElementChild.focus();'><div onkeydown='event.preventDefault();' tabindex=0>Test</div></body>" line: 0}]
13:28:34     INFO - TEST-PASS | browser/base/content/test/permissions/browser_reservedkey.js | reserved='true' with preference off - 
13:28:34     INFO - TEST-PASS | browser/base/content/test/permissions/browser_reservedkey.js | reserved='false' with preference off - 
13:28:34     INFO - TEST-PASS | browser/base/content/test/permissions/browser_reservedkey.js | default reserved with preference off - 
13:28:34     INFO - TEST-PASS | browser/base/content/test/permissions/browser_reservedkey.js | reserved='true' with preference on - 
13:28:34     INFO - TEST-PASS | browser/base/content/test/permissions/browser_reservedkey.js | reserved='false' with preference on - 
13:28:34     INFO - TEST-PASS | browser/base/content/test/permissions/browser_reservedkey.js | default reserved with preference on - 
13:28:34     INFO - Leaving test bound test_reserved_shortcuts
13:28:34     INFO - Entering test bound test_backspace
13:28:34     INFO - Buffered messages logged at 13:27:07
13:28:34     INFO - Console message: [JavaScript Error: "SyntaxError: expected expression, got '}'" {file: "data:text/html,<body onbeforeunload='document.getElementById('field').value = 'failed'; event.preventDefault();'><input id='field' value='something' autofocus></body>" line: 2 column: 0 source: "}"}]
13:28:34     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<body onbeforeunload='document.getElementById('field').value = 'failed'; event.preventDefault();'><input id='field' value='something' autofocus></body>" line: 0}]
13:28:34     INFO - Buffered messages finished
13:28:34     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/permissions/browser_reservedkey.js | backspace not prevented - Got something, expected omething
13:28:34     INFO - Stack trace:
13:28:34     INFO - chrome://mochikit/content/browser-test.js:test_is:1312
13:28:34     INFO - chrome://mochitests/content/browser/browser/base/content/test/permissions/browser_reservedkey.js:test_backspace:141
13:28:34     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1102
13:28:34     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1093
13:28:34     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:991
13:28:34     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
13:28:34     INFO - Leaving test bound test_backspace
13:28:34     INFO - GECKO(851) | [Child 853, Main Thread] WARNING: SendNotifyIMEFocus got rejected.: file /builds/worker/workspace/build/src/widget/PuppetWidget.cpp, line 779
13:28:34     INFO - GECKO(851) | MEMORY STAT | vsize 4423MB | residentFast 333MB | heapAllocated 105MB
13:28:34     INFO - TEST-OK | browser/base/content/test/permissions/browser_reservedkey.js | took 1347ms
13:28:34     INFO - GECKO(851) | ++DOCSHELL 0x124dc9000 == 3 [pid = 853] [id = {939edc05-d69f-9d4f-bc8c-6806a1b2ad45}]
13:28:34     INFO - GECKO(851) | ++DOMWINDOW == 9 (0x125e05800) [pid = 853] [serial = 17] [outer = 0x0]
13:28:34     INFO - GECKO(851) | ++DOMWINDOW == 10 (0x125e09c00) [pid = 853] [serial = 18] [outer = 0x125e05800]
13:28:34     INFO - GECKO(851) | [Child 853, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 8205
13:28:34     INFO - GECKO(851) | ++DOMWINDOW == 11 (0x125e10c00) [pid = 853] [serial = 19] [outer = 0x125e05800]
13:28:34     INFO - GECKO(851) | [Child 853, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 8205
13:28:34     INFO - checking window state

Push with failures:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&group_state=expanded&revision=648648a60190278663379270879e053c9d767f70

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/303797fd37227647995d902c220177df611c58e3
Flags: needinfo?(enndeakin)
This bug is OK. The failure is caused by 1445942.
Flags: needinfo?(enndeakin)
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5e4074b128f9
add some null-pointer checks on elements in XULListboxAccessible, r=marcoz
https://hg.mozilla.org/mozilla-central/rev/5e4074b128f9
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Blocks: 1518113
You need to log in before you can comment on or make changes to this bug.