Closed Bug 1513341 Opened 2 years ago Closed 2 years ago

Restarting the browser only quits it, it doesn't start it again | restart-to-update broken

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 + fixed
firefox66 + fixed

People

(Reporter: mstange, Assigned: spohl)

References

Details

(Keywords: regression)

No description provided.
Steps to reproduce:
 1. Trigger a restart of your browser, for example from the update notification, or by executing the following on the Error Console:

Services.startup.quit(Ci.nsIAppStartup.eRestart | Ci.nsIAppStartup.eAttemptQuit);

Expected results:
The browser should quit and then start.

Actual results:
All windows close, an extra Dock icon briefly appears and then vanishes, then the app quits, and it doesn't start again.
Summary: Restarting the browser only quits it, it doesn't start it again restart-to-update broken → Restarting the browser only quits it, it doesn't start it again | restart-to-update broken
This doesn't always happen; I think it only happens if the act of quitting the browser takes some time, for example after a long browser session that requires more cleanup.
A regression range would be useful, or maybe seeing if this is specific to one version of MacOS or happens across all the versions.
It's likely to be a regression from bug 469990, but I haven't verified that.
Assignee: nobody → spohl.mozilla.bugs
Status: NEW → ASSIGNED
See Also: → 1513328
Duplicate of this bug: 1513640
See Also: 1513328
I can't reproduce your issue. Please try to try to reproduce again and provide us with the actions made inside the browser to attempt to reproduce the actions you make.

Also, please answer these questions:
1. Which Mac OS X version are you using?
2. Which Apple device are you using?
3. Does it also occur in the case of the latest Beta or Nightly browsers?
4. Can you find out whether bug 469990 is the regressor of your issue?

Thank you for your contribution!
Flags: needinfo?(mstange)
(In reply to Bodea Daniel [:danibodea] from comment #6)
> I can't reproduce your issue.

I can reproduce and I'm looking into it.
Flags: needinfo?(mstange)
I came across this as well. macOS 10.14 and Nightly 66. I think 65 may also be affected but have not tested it.
Duplicate of this bug: 1513823
Fixed by the backout of bug 469990 (cset 590bdef6b312) which will be merged to beta shortly.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
The backout has been landed on Beta and will be included in the 65.0b5 release.
https://hg.mozilla.org/releases/mozilla-beta/rev/978402f68f3c
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.