Closed Bug 1513431 Opened 9 months ago Closed 9 months ago

Open All in Tabs button in the Bookmarks Menu regressed in Firefox Developer Edition 2018-12-11

Categories

(Firefox :: Bookmarks & History, defect)

65 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1512180

People

(Reporter: mozilla, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

- When I updated Firefox developer edition (2018-12-11, Aurora channel, OSX).
- Clicked the bookmark menu button, clicked a folder.
- Clicked Open All in Tabs


Actual results:

Nothing Happened


Expected results:

All links should have opened.

Same thing happens with all extensions disabled.
Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Component: Untriaged → Bookmarks & History
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1512180
Reopening, as I'm not convinced this is a duplicate as the dates are different.

Reporter, can you clarify the steps to repeat a bit more? I've just tried this on the nightly of the same date and this is working fine for me. Maybe a screencast or screenshot would help.

You could also go to Tools -> Web Developer -> Browser Console and see if any errors appear when you select the "open all in tabs" option.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(mozilla)
Resolution: DUPLICATE → ---
You are right, got a message

TypeError: PlacesUIUtils.openContainerNodeInTabs is not a function[Learn More] browser.xul:1:1 
    	oncommand chrome://browser/content/browser.xul:1 

On updating again to from in the about 65.0b2 (64-bit) to 65.0b3 (64-bit), the bug went away. It is possible my nightly was a few days old?
Flags: needinfo?(mozilla)
Aha you were on the developer edition version, that's not quite equivalent to nightly (having the version number as well as the data helps!).

This is a dupe in that case.
Status: REOPENED → RESOLVED
Closed: 9 months ago9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1512180
You need to log in before you can comment on or make changes to this bug.