Closed Bug 1513471 Opened 2 years ago Closed 2 years ago

2.82 - 5.63% tp5o_webext responsiveness (linux64) regression on push 2c48655b33ca454f532c9d47b6b386b13b0e7ca0 (Thu Dec 6 2018)

Categories

(Core :: JavaScript: GC, defect)

61 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: igoldan, Assigned: allstars.chh)

References

(Blocks 1 open bug)

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7dee627d2f740f0190ae1be201ac3bf9eaaa5659&tochange=2c48655b33ca454f532c9d47b6b386b13b0e7ca0

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  6%  tp5o_webext responsiveness opt e10s stylo     1.68 -> 1.78
  3%  tp5o_webext responsiveness pgo e10s stylo     1.44 -> 1.48


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=18074

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling
Component: General → JavaScript: GC
Product: Testing → Core
Flags: needinfo?(allstars.chh)
I noticed similar regressions on the Windows platforms as well.
I'll soon post the Gecko profiles.
(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #0)
> 
> Regressions:
> 
>   6%  tp5o_webext responsiveness opt e10s stylo     1.68 -> 1.78
>   3%  tp5o_webext responsiveness pgo e10s stylo     1.44 -> 1.48
> 

These regressions are from Linux 64bit OPT and PGO, respectively.
It seems my hope in bug 1510607 comment 1 was misplaced.  Let's back this out until we work out what's happening.
:igoldan
I need more time to check the cause,
could you back out my patch from Bug 1510607 first?

Thanks
Flags: needinfo?(allstars.chh)
Which is faster for tp5o responsiveness: higher or lower scores?

The score is getting lower and lower (on all measured platforms) since December 10:

https://treeherder.mozilla.org/perf.html#/graphs?timerange=5184000&series=mozilla-central,1538732,1,1&series=mozilla-central,1538727,1,1&series=mozilla-central,1652648,1,1
(In reply to Chris Peterson [:cpeterson] from comment #7)
> Which is faster for tp5o responsiveness: higher or lower scores?

Lower is better. If you hover over the data points in Perfherder you should see "(lower is better)" after the value.

> The score is getting lower and lower (on all measured platforms) since
> December 10:
> 
> https://treeherder.mozilla.org/perf.html#/
> graphs?timerange=5184000&series=mozilla-central,1538732,1,1&series=mozilla-
> central,1538727,1,1&series=mozilla-central,1652648,1,1

Could this be due to the backout of bug 1510607 as requested in comment 6?
(In reply to Dave Hunt [:davehunt] [he/him] ⌚️UTC from comment #8)
> Could this be due to the backout of bug 1510607 as requested in comment 6?

Thanks. I missed that comment about the backout.
Fixed by backout on all affected branches.
Assignee: nobody → allstars.chh
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.