Closed Bug 1513568 Opened 2 years ago Closed 2 years ago

SSH Google Cloud Console - Not Working

Categories

(Core :: General, defect)

64 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1503241

People

(Reporter: amir72, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

https://ssh.cloud.google.com/{details of my VM connetion}


Actual results:

On Firefox 64.0 - connection established but nothing is displayed (black empty GUI).


Expected results:

After establishing the connection, the console prompt should have been visible - like in Firefox 63.x and Chrome.
I do not have access to a google cloud VM and therefore can not test this.

In case that this is really regression inm Firefox64 can you please run our regression finder tool to find the change in the source that caused this ?
- https://mozilla.github.io/mozregression/
Flags: needinfo?(amir72)
It did work OK on Nightly 62, 64.0a1, 
Still not working on Quantum 64.0.
Not sure whether the logs were completely pushed.

Please let me know if that requires any re-run.

Thanks!
Flags: needinfo?(amir72)
Also - doesn't work on latest Dev 65.0b3
Hello there

I can confirm this error occurring on Firefox 64.0 on Windows 10 and on Firefox (not sure about the version, computer is on office and locked for the holidays) on Ubuntu 18.0.4.
Adding to what amir72 said, the terminal icons for keyboard and setting are blurred as pointed in the samples below and the terminal is unresponsive (typing "exit" and pressing <ENTER> should close the terminal, but nothing happens).

Expected Results: Good Terminal on Firefox Nightly 2012-10-07 - https://prnt.sc/m0ou3b

Actual Results: Bugged Terminal on Firefox 64.0 - https://prnt.sc/m0oxxr


I ran mozregression-gui on Windows and reached the following results:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=982f91f69b39773ac302d4d01610de1414894529&tochange=113ba8a072a6cb6074fe176fe84965bbd7a1970d

mozregression-gui screen: http://prntscr.com/m0orhy
Thank you very much fior the regression range !

This is most likely a regression from bug 1497126 , bug 1475139 or bug 1475139.
Can you 3 (:baku,:Rhunt,:froydn) please take a look if your patch can be respnsible for this regression ?
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Product: Firefox → Core
Matthias and mhauer - is there a wiki/help section I can read to get familiar with the mozregression tool? Thanks.
mhauer did already the work. There is the youtube video linked on the mozregression page and there is also documentation on the page for the commandline version.
(In reply to Matthias Versen [:Matti] from comment #5)
> Thank you very much fior the regression range !
> 
> This is most likely a regression from bug 1497126 , bug 1475139 or bug
> 1475139.
> Can you 3 (:baku,:Rhunt,:froydn) please take a look if your patch can be
> respnsible for this regression ?

Please use needinfo if you need people to take a look at something.

I don't see any of my bugs in the above list.  Did you mistype a bug number?
Sorry, I meant this 3 bugs in the regression range from comment#4:

Nathan Froyd — Bug 1483699 - part 1 - add overflow checks for extending arrays; r=mccr8
Ryan Hunt — Bug 1475139 part 12 - Expose drawSnapshot API to <browser>. r=nika
Andrea Marchesini — Bug 1497126 - Allow 1 level of recursion when loading nested iframes with same URL, r=smaug
Flags: needinfo?(nfroyd)
It's possible that bug 1483699 is responsible, but that's a pretty low-level change to cause website issues.  I'd be more inclined to look at bug 1497126 first.
Flags: needinfo?(nfroyd) → needinfo?(amarchesini)
this is a dupe of bug 1503241...
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1503241
Flags: needinfo?(amarchesini)
You need to log in before you can comment on or make changes to this bug.