Crash in mozilla::wr::ImageDescriptor::ImageDescriptor when opening PDFs (Linux x64 XWayland)

RESOLVED FIXED in mozilla66

Status

()

RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: darkspirit, Assigned: sotaro)

Tracking

(Blocks: 2 bugs, 4 keywords)

Trunk
mozilla66
x86_64
Linux
crash, nightly-community, regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 disabled, firefox66 disabled)

Details

(crash signature)

Attachments

(1 attachment)

(Assignee)

Comment 1

3 months ago
I found one STR to cause the crash. It was enabling SkiaGL by pref. But SkiaGL is disabled by default by Bug 1468801.

[1] Set gfx.webrender.all;true to about:config
[2] Set gfx.canvas.azure.accelerated;true to about:config
[3] Restart Firefox.
[4] Load pdf on Firefox.
(Assignee)

Comment 2

3 months ago
Laurentiu Nicola, did you enabled SkiaGL? Thanks!
Flags: needinfo?(grayshade)
(Reporter)

Comment 3

3 months ago
Confirmed STR from comment 1. Only crashes with Wayland KDE and not with Xorg KDE.
bp-65602d70-1d08-4573-ac33-1d0b90181213
Blocks: 1491303
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

3 months ago
mozregression --repo autoland --good 2018-11-14 --bad 2018-11-15 --pref gfx.webrender.all:true gfx.canvas.azure.accelerated:true -a https://www.privacy-handbuch.de/download/privacy-handbuch.pdf
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e762fce85daa2b0399f443c4644c6e61a11b1eb3&tochange=6fc6bdea42a60b7e3fb426beb073e07a3922913c

> 6fc6bdea42a6	Mike Hommey — Bug 1501218 - Enable wayland support with --enable-default-toolkit=cairo-gtk3. r=mshal
> 1840a5cbb59f	Mike Hommey — Bug 1507030 - Use the same docker image for opt and debug base-toolchain jobs. r=froydnj
> 1f1eec6abd9b	Mike Hommey — Bug 1507032 - Work around bug in wayland (< 1.12) headers. r=froydnj


RUST_BACKTRACE=1 mozregression --launch 2018-12-12 -B debug --pref gfx.webrender.all:true gfx.canvas.azure.accelerated:true -a https://www.privacy-handbuch.de/download/privacy-handbuch.pdf
> 0:47.33 INFO: [GFX2-]: Using SkiaGL canvas.
> 0:47.46 INFO: Assertion failure: false, at /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/webrender/WebRenderTypes.h:72

https://searchfox.org/mozilla-central/rev/3160ddc1f0ab55d230c595366662c62950e5c785/gfx/webrender_bindings/WebRenderTypes.h#72
>    case gfx::SurfaceFormat::R8G8B8X8:
>      // WebRender not support RGBX8. Assert here.
>      MOZ_ASSERT(false);
(Reporter)

Updated

3 months ago
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox64: --- → unaffected
status-firefox65: --- → disabled
status-firefox66: --- → disabled
status-firefox-esr60: --- → unaffected
Keywords: regression, reproducible
(Assignee)

Comment 5

3 months ago
It seems better just disable SkiaGL for now, since Bug 1468801 disables SkiaGL and there is no plan to re-enable it.
(Assignee)

Updated

3 months ago
Assignee: nobody → sotaro.ikeda.g

Comment 7

3 months ago
Disabling gfx.canvas.azure.accelerated fixes the crash for me.
Flags: needinfo?(grayshade)
(Assignee)

Comment 8

3 months ago
Thanks for the quick response :)

Comment 9

3 months ago
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e79c7b512fd6
Disable SkiaGL on WebRender r=jrmuizel

Comment 10

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e79c7b512fd6
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.