JRE font selection issues

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: jbetak@netscape.com (away - not reading bugmail), Assigned: Ping Liao)

Tracking

({intl})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)
BuildID:    2002053012

Yahoo Chess runs in a Java applet (see screenshot), which works fine in both IE 
and Mozilla. When running it on Mozilla though, some of some fonts are 
inlegible. This is odd and might be a Sun issue - MS JVM doesn't have the 
problem. I could have tried to replace the MS JVM with Sun's JRE and run the 
applet in IE again, but I haven't had time (and the inclination) to do it.

I'm filing this bug to have it logged and possibly routed to the proper dev. 
team.

Reproducible: Always
Steps to Reproduce:
1. log into yahoo
2. go to the games section
3. pick chess
4. log into any group, watch the applet load
5. see player status messages - the font is illegible

Actual Results:  player status messages are illegible

Expected Results:  player status messages should be legible
Created attachment 87461 [details]
Mozilla running Y!Chess applet
Created attachment 87462 [details]
IE running Y!Chess applet
Changing component to "browser general", could you please advise on the proper
owner for this bug?
Component: Java APIs to WebShell → Browser-General
changing asignee
Assignee: joe.chou → Matti
QA Contact: avm → asa
i have no Yahoo Account...
Which JRE do you use ?
Is the font problem inside the applet ?
if yes -> Oji, if not -> Can you attach the html ?

Matti, 

thanks for helping us out. I believe the font problem happens inside the applet 
with Sun's JRE. I believe we haven't tested Microsoft's JRE yet. It seems that 
the JRE makes a less than optimal font selection based on the information 
passed from the browser. I'll try to attach the page source tomorrow. 

Jamila, is there anything I missed or misrepresented?
OK, seems like this is an OJI issue. Thanks for your help Matti! 

-> Back to Joe. Joe, can you please confirm this bug? I'm getting the 
impression that Bugzilla is not regularly monitored on Sun's side of the fence.
Assignee: Matti → joe.chou
Component: Browser-General → OJI
QA Contact: asa → pmac

Comment 8

16 years ago
Re-assign to Ping.
Assignee: joe.chou → ping.liao
Joe, thanks for your follow-up. I believe this issue still persists. 

I could try to pull in Brian Stell to provide some insights on client font
handling. I think it might be helpful, although this bug looks like a pretty
clear-cut JVM issue...

Comment 10

16 years ago
it looks like IE's minimum font size is larger than the JVM (if it even has a
minimum font size)
hmm, that's an interesting idea Brian. Thanks for looking at this?

Ping, any chance you might get around to working on this? Stupid question: is
the JRE code part of the Mozilla tree or is it closed-source?
(Assignee)

Comment 12

16 years ago
To answer jbetak's question, I have a few higher priority tasks to take care
before I have time to get to this one.  JRE code is basically closed-source.
Ping, thanks for clarifying the status of this bug. I can see how this can be a
low priority issue :-) 

The reason for filing this was the font selection (minimum size) problem likely
affects other applets as well and might be worth the bother - sooner or later.

Updated

16 years ago
QA Contact: pmac → petersen

Comment 14

15 years ago
*** Bug 229364 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: intl
The font size looks ok with SM 1.9.1 branch and JRE1.6U11
marking wfm
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.