Closed Bug 1513956 Opened 2 years ago Closed 2 years ago

The summary in the history contains additional white spaces

Categories

(bugzilla.mozilla.org :: General, defect)

Production
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: marco, Assigned: kohei.yoshino)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
16:29 <marco> dylan: https://bugzilla.mozilla.org/rest/bug/1368258
16:29 <marco> https://bugzilla.mozilla.org/rest/bug/1368258/history
16:29 <marco> the summary in the history has a whitespace at the end
16:30 <marco> "Intermittent Assertion failure: aDurationMs <= totalMs, at z:/build/build/src/layout/painting/nsDisplayList.cpp:8793 "
16:30 <marco> instead of
16:30 <marco> "Intermittent Assertion failure: aDurationMs <= totalMs, at z:/build/build/src/layout/painting/nsDisplayList.cpp:8793"
Component: API → General

This is what I get with SELECT * FROM bugs_activity WHERE bug_id = 1368258;

+---------+--------+---------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------------------------------------------------------------------------------------------------------------------------------+-----------+------------+-----------+---------------------+
| bug_id  | who    | fieldid | removed                                                                                                                                                                                                                               | added                                                                                                                          | attach_id | comment_id | id        | bug_when            |
+---------+--------+---------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------------------------------------------------------------------------------------------------------------------------------+-----------+------------+-----------+---------------------+
| 1368258 | 473875 |      37 |                                                                                                                                                                                                                                       | mtseng@mozilla.com                                                                                                             |      NULL |       NULL | 308240963 | 2017-05-30 20:25:41 |
| 1368258 | 473875 |      22 |                                                                                                                                                                                                                                       | [gfx-note]                                                                                                                     |      NULL |       NULL | 308240964 | 2017-05-30 20:25:41 |
| 1368258 | 473875 |      22 | [gfx-note]                                                                                                                                                                                                                            | [gfx-noted]                                                                                                                    |      NULL |       NULL | 308240978 | 2017-05-30 20:28:15 |
| 1368258 | 456486 |      32 | --                                                                                                                                                                                                                                    | P3                                                                                                                             |      NULL |       NULL | 308443638 | 2017-07-18 08:18:57 |
| 1368258 | 258347 |      24 | Intermittent layout/reftests/w3c-css/submitted/text-decor-3/text-emphasis-position-property-005d.html | application crashed [@ <lambda_6d48001a44d55e6c39a0e00e76378b78>::operator()] after Assertion failure: aDurationMs <= totalMs | Intermittent Assertion failure: aDurationMs <= totalMs, at z:/build/build/src/layout/painting/nsDisplayList.cpp:8793           |      NULL |       NULL | 308453909 | 2017-07-20 04:10:18 |
| 1368258 | 258347 |      24 | , at nsDisplayList.cpp:879                                                                                                                                                                                                            |                                                                                                                                |      NULL |       NULL | 308453910 | 2017-07-20 04:10:18 |
| 1368258 | 258347 |      37 |                                                                                                                                                                                                                                       | intermittent-bug-filer@mozilla.bugs                                                                                            |      NULL |       NULL | 308453913 | 2017-07-20 04:10:48 |
+---------+--------+---------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------------------------------------------------------------------------------------------------------------------------------+-----------+------------+-----------+---------------------+

I don’t know why this could have happened but the 6th item , at nsDisplayList.cpp:879 is garbage, which is the culprit of the bug. The history code tries to merge duplicated items changed at the same time, and the joiner adds a space between those two. I can fix it.

Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1513995
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.