Flash plugin can not save settings

VERIFIED FIXED in Firefox 66

Status

()

P2
normal
VERIFIED FIXED
3 months ago
18 days ago

People

(Reporter: Matti, Assigned: handyman)

Tracking

({regression})

Trunk
mozilla67
regression
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 wontfix, firefox66+ verified, firefox67+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Firefox 66 nightly on windows10 and C:\WINDOWS\system32\Macromed\Flash\NPSWF64_32_0_0_101.dll


While investigating bug 1513966 I discovered that the Flash plugin can not save it settings anymore

> 9:33.11 INFO: No more inbound revisions, bisection finished.
> 9:33.11 INFO: Last good revision: ba708fde30b8f8d2ae4d1febfa2e88e2c1bf1cc4
> 9:33.11 INFO: First bad revision: a910482f4598931944910a357431b22f823578fb
> 9:33.11 INFO: Pushlog:
>https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ba708fde30b8f8d2ae4d1febfa2e88e2c1bf1cc4&tochange=a910482f4598931944910a357431b22f823578fb


STR:
1) load https://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html
2) change for example the global storage setting to 10MB
3) switch the tab inside the flash settings area (example: Privacy settings) and switch back to the global storage tab
4) the changed setting from step 2 is back to it's original setting.

setting dom.ipc.plugins.sandbox-level.flash to "0" followed by a restart fixes the problem.
(Reporter)

Updated

3 months ago
Flags: needinfo?(davidp99)
(Assignee)

Comment 1

3 months ago
This may or may not be the SharedObject thing from bug 1513966.  I've been looking into the issue from that end.  With luck, that will resolve this.
Assignee: nobody → davidp99
Flags: needinfo?(davidp99)
Priority: -- → P2
tracking-firefox66: --- → ?
tracking-firefox66: ? → +
See Also: → bug 1513966

[Tracking Requested - why for this release]:
We're not going to get a fix for 66, so 67 is the new target.

status-firefox66: affected → wontfix
status-firefox67: --- → affected
tracking-firefox67: --- → ?
tracking-firefox67: ? → +

Updated

2 months ago
Duplicate of this bug: 1523929
(Assignee)

Updated

2 months ago
Duplicate of this bug: 1513966
(Assignee)

Comment 5

2 months ago

I duped bug 1513966 to this issue. This fix for this (coming soon) also fixes that issue. STR that demo the case in bug 1513966:

  1. Go to https://www.permadi.com/tutorial/flashSharedObject/index.html
  2. Scroll down to the applets and select one to click-to-play. Permit Flash to run.
  3. Example 3 shows : "Number of times you have visited this page: 1". Reload the page.

Expected results:
Example 3 shows : "Number of times you have visited this page: 2"

Actual results:
Example 3 shows : "Number of times you have visited this page: 1" again.

(Assignee)

Comment 6

2 months ago

The sandbox already permits the process to create/delete the folder and access files in it. This patch gives is access to the folder itself, namely it allows NtQueryAttributesFile to evaluate it. For complex reasons, this fixes Flash's ability to store local objects (see AS3's SharedObject API).

Comment 8

2 months ago
Pushed by daparks@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6868dec34052
Allow Windows plugin process to access Macromedia roaming folder (r=bobowen)

The fix here is pretty minimal and safe, so an uplift to 66 is possible.

status-firefox66: wontfix → affected

Comment 10

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox67: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

jimm, can you request uplift since it looks like David is on PTO?
Andrei, can your team verify the fix? Thanks!

Flags: qe-verify+
Flags: needinfo?(jmathies)
Flags: needinfo?(andrei.vaida)

Comment 12

2 months ago

I can confirm that the issue isn't reproducible any more on Windows 10 x64 and on Ubuntu 16.04 x64 on the latest Firefox Nightly 67.0a1 (2019-02-05).

But on Mac OS X 10.14 I faced the same issues mentioned in the user story and in comment 5.
Is this expected?
Thanks.

Flags: needinfo?(davidp99)
status-firefox65: --- → wontfix
status-firefox-esr60: --- → unaffected
Flags: needinfo?(andrei.vaida)

Haik, maybe we need a similar fix on OSX?

Flags: needinfo?(jmathies)
Flags: needinfo?(haftandilian)
Flags: needinfo?(davidp99)

Comment on attachment 9040600 [details]
Bug 1514073: Allow Windows plugin process to access Macromedia roaming folder (r?bobowen)

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

sandbox work

User impact if declined

flash settings not saved

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

Bug 1514073

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

adding a directory access exclusion, low risk change.

String changes made/needed

Attachment #9040600 - Flags: approval-mozilla-beta?
Blocks: 1525625
No longer blocks: 1525625

(In reply to Jim Mathies [:jimm] from comment #13)

Haik, maybe we need a similar fix on OSX?

I've filed bug 1525625 to address this.

Flags: needinfo?(haftandilian)
See Also: → bug 1525625

Comment on attachment 9040600 [details]
Bug 1514073: Allow Windows plugin process to access Macromedia roaming folder (r?bobowen)

Fix for sandboxing Flash settings on Windows, OK to uplift for beta 6.

[Triage Comment]

Attachment #9040600 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 17

a month ago
bugherderuplift
status-firefox66: affected → fixed

Updated

a month ago
Duplicate of this bug: 1525832

Comment 19

a month ago

Since bug 1525625 was logged for the issue on Mac, I'll mark this as verified as fixed on Windows 10 x64 and on Ubuntu 16.04 x64.

Status: RESOLVED → VERIFIED
status-firefox67: fixed → verified
Whiteboard: [qa-triaged]

Jim, this looks like a pretty safe patch. Is this something we might want to include as a ride-along for 65.0.1?

Flags: needinfo?(jmathies)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #20)

Jim, this looks like a pretty safe patch. Is this something we might want to include as a ride-along for 65.0.1?

@Ryan, we have the same problem on Mac (bug 1525625) and the fix will probably also be low risk. I think the Mac fix will land within the next few days. If the timing lines up, it would be nice to fix this on both platforms.

Comment 22

a month ago

Verified as fixed on Firefox 66.0b6 on Windows 10 x64 and on Ubuntu 16.04 x64.

status-firefox66: fixed → verified
Flags: qe-verify+

(In reply to Ryan VanderMeulen [:RyanVM] from comment #20)

Jim, this looks like a pretty safe patch. Is this something we might want to
include as a ride-along for 65.0.1?

Sure, that seems ok.

Flags: needinfo?(jmathies)
QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.