MFCEmbed - Unable to reload single frame in frameset using reload in context menus

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
17 years ago
7 years ago

People

(Reporter: amutch, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.1a) Gecko/20020612
BuildID: MFCEmbed June 12, 2002 nightly build    

If you visit a site with frames and try to reload an individual frame using
reload in a context menu, the entire frameset is reloaded. Only the selected
frame should be reloaded.

Reproducible: Always
Steps to Reproduce:
1. Open a site with frames that loads individual pages within the frameset
2. Select a link in the frameset to load a new page
3. Right-click in the page and select reload
4. Browser reloads original frameset

Expected Results:  Browser should only reload selected frame.

Comment 1

17 years ago
-> Chak
Assignee: adamlock → chak

Comment 2

16 years ago
I noticed this while testing our webapp too. Go to a frameset (index) and have
it load 2 frames (index1, index2). Have a link in the bottom frame that goes to
index3. You should now be staring at index with index1 on the top and index3 at
the bottom. Right clicking in the bottom frame and going to "reload" takes you
back to index1 and index2, losing your progress through the frameset. 

This won't take much time to confirm. I am seeing it in 1.1, and a coworker
using 1.2B can also reproduce it. (Of course I have no idea how long it will
take to fix)

This is pretty important for testing our web application, and I'd love y'all
forever if it went away.

Thanks!

Updated

16 years ago
QA Contact: mdunn → ashishbhatt
(Reporter)

Comment 3

16 years ago
Is there any functions that support this kind of behavior? I dug through the 
code for Mozilla but in Mozilla, this is done with Javascript. This one:

void CBrowserView::OnNavReload() 
{
	if(mWebNav)
		mWebNav->Reload(nsIWebNavigation::LOAD_FLAGS_NONE);
}

doesn't seem to be granular enough to discriminate between individual pages. 
It just loads the top window URL reference.
(Reporter)

Comment 4

16 years ago
We've been digging through the Mozilla code and we weren't able to find any 
code that provides the functionality to reload a single frame 
page. "CBrowserView::OnNavReload()" reloads the entire frameset and I haven't 
had any luck refocusing it to a single frame. Can either of the following 
happen:

1) A demonstration of how to use "CBrowserView::OnNavReload()" to reload a 
single frame.

2) The creation of a new function that provide for reloading of a single page 
within a frameset.

Thanks!

Comment 5

15 years ago
The usual stuff applies. Can you try this on a recent nightly?
(Reporter)

Comment 6

15 years ago
This still doesn't work in the current nightly of MFCEmbed. We wrote our own 
code for K-Meleon to handle this. A patch could be submitted if so desired.

Comment 7

15 years ago
it wouldn't hurt to have the patch, even if it doesn't make it into cvs, please
post it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

15 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Recent Mozilla 1.5 RC1

The submenu "This frame" in the context menu doesn't show up...
Just visit a page with frames and rightclick in the frame.
Then just *try* to enter the submenu "This frame". ;)
I bet you can't reach any of submenus...

Greetz
Bjoern

Comment 9

14 years ago
Same for me.
Assignee: chak → nobody
QA Contact: ashshbhatt → apis
Mass marking all MFCEmbed bugs as wontfix, since bug 377410 removed it. If this bug was erroneously included (or say equally applies to winEmbed), please reopen & accept my apologies.

Filter bugspam on mfcEmbedwontfix.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.