Closed Bug 1514273 Opened 11 months ago Closed 11 months ago

Update in-tree copies of compare-locales and Fluent to 5.1 and 0.10

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: Pike, Assigned: Pike)

Details

Attachments

(1 file)

There's no changes to mach or migrations this time around, just copy in c-l and python-fluent.
Pushed by axel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/83707acc26ef
update in-tree copies of compare-locales and Fluent to 5.1 and 0.10, r=stas
https://hg.mozilla.org/mozilla-central/rev/83707acc26ef
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Comment on attachment 9031474 [details]
bug 1514273, update in-tree copies of compare-locales and Fluent to 5.1 and 0.10, r=stas

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: This is part of a regular update of the l10n system, due to the cross-channel requirements. This patch adds build system support for new features in .ftl files. Once we turn these features on in Pontoon, localizers can start using them in translations. Both central and beta should be ready to read them.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: Bug 1513958

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This patch updates the in-tree versions of two third-party libraries, compare-locales and fluent. Both have been updated to their most recent published versions and have been tested before being published.

String changes made/needed:
Attachment #9031474 - Flags: approval-mozilla-beta?
Comment on attachment 9031474 [details]
bug 1514273, update in-tree copies of compare-locales and Fluent to 5.1 and 0.10, r=stas

[Triage Comment]
Updates our in-tree copies of compare-locales and Fluent so that localizers can make use of their features without having to worry about incompatibilities between Trunk and Beta. Approved for 65.0b7.
Attachment #9031474 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.