Identity popup (x) icon should not get its color overriden by button.css

VERIFIED FIXED in Firefox 65

Status

()

defect
VERIFIED FIXED
6 months ago
6 months ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

({regression})

unspecified
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 verified, firefox66 verified)

Details

Attachments

(4 attachments)

Assignee

Description

6 months ago
Posted image Screenshot
See the screenshot.
Assignee

Comment 1

6 months ago
Posted image After the fix
Assignee

Updated

6 months ago
Assignee: nobody → ehsan

Comment 3

6 months ago
Regression of bug 1473922 which increased the specificity of the rules in button.css.

The hover state is only broken on Linux by the button:hover rule in button.css, and the active state is broken on macOS by the button:hover:active rule.
Blocks: 1473922
Keywords: regression
Summary: The hover state of the x icon next to the Allowed labels in the Cookies subpanel is invisible in the dark theme → Identity popup (x) icon should not get its color overriden by button.css

Comment 4

6 months ago
The current patch won't solve macOS, so what dao suggests on Phabricator is the right path.

Comment 5

6 months ago
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/968da4151968
Give the correct foreground color to the hover state of the X button next to the Allowed label in the Cookies subpanel in the Control Centre r=dao
Assignee

Comment 6

6 months ago
Comment on attachment 9031484 [details]
Bug 1514277 - Give the correct foreground color to the hover state of the X button next to the Allowed label in the Cookies subpanel in the Control Centre

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1473922

User impact if declined: See comment 0

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 1. Use the dark theme (right click on toolbar, select Customize)
2. Go to https://senglehardt.com/test/identity_providers/google_custom.html.
3. Click on the Google button.
4. Click somewhere on the opened popup.
5. Close the pop-up.
6. In the previous window, open the Control Centre.
7. Click on Cookies.
8. Hover the "X" button next to Allowed.

List of other uplifts needed: None.

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): A small CSS change

String changes made/needed: None
Attachment #9031484 - Flags: approval-mozilla-beta?

Comment 7

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/968da4151968
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Flags: qe-verify+
Comment on attachment 9031484 [details]
Bug 1514277 - Give the correct foreground color to the hover state of the X button next to the Allowed label in the Cookies subpanel in the Control Centre

[Triage Comment]
Minor CSS tweak, approved for 65.0b5.
Attachment #9031484 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I successfully reproduced the issue on Firefox Nightly 66.0a1 (2018-12-14) under Ubuntu 16.04 (x86).

The issue is not reproducible anymore on Firefox Beta 65.0b5 (20181216183345) and latest Firefox Nightly 66.0a1 (2018-12-17) under Ubuntu 16.04 (x86)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.