Closed Bug 1514485 Opened 6 years ago Closed 5 years ago

Crash in webrender::render_backend::FrameResources::as_common_data

Categories

(Core :: Graphics: WebRender, defect, P3)

x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fix-optional

People

(Reporter: jan, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, nightly-community, regression)

Crash Data

Seen on Socorro.

This bug was filed from the Socorro interface and is
report bp-8a6dabad-6842-4773-95bb-1dff20181215.
> assertion failed: `(left == right)`
>  left: `Epoch(4503599627429117)`,
> right: `Epoch(58621)`
=============================================================

Top 10 frames of crashing thread:

0 libxul.so MOZ_CrashOOL mfbt/Assertions.h:314
1 libxul.so GeckoCrashOOL toolkit/xre/nsAppRunner.cpp:5118
2 libxul.so gkrust_shared::panic_hook toolkit/library/rust/shared/lib.rs:234
3 libxul.so core::ops::function::Fn::call libcore/ops/function.rs:78
4 libxul.so std::panicking::rust_panic_with_hook /rustc/abe02cefd6cd1916df62ad7dc80161bea50b72e8/src/libstd/panicking.rs:480
5 libxul.so std::panicking::continue_panic_fmt /rustc/abe02cefd6cd1916df62ad7dc80161bea50b72e8/src/libstd/panicking.rs:390
6 libxul.so std::panicking::begin_panic_fmt /rustc/abe02cefd6cd1916df62ad7dc80161bea50b72e8/src/libstd/panicking.rs:345
7 libxul.so webrender::render_backend::FrameResources::as_common_data gfx/wr/webrender/src/render_backend.rs
8 libxul.so webrender::prim_store::PrimitiveStore::prepare_prim_for_render gfx/wr/webrender/src/prim_store/mod.rs:2489
9 libxul.so webrender::prim_store::PrimitiveStore::prepare_primitives gfx/wr/webrender/src/prim_store/mod.rs:2781

=============================================================

Low volume. Not blocking

Priority: -- → P3

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.