Closed Bug 1514539 Opened 8 months ago Closed 7 months ago

(picture-caching) MotionMark score becomes lower with picture caching

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: sotaro, Assigned: gw)

References

(Blocks 1 open bug)

Details

Without picture caching, MotionMark score was 130-150 on P50(Win10). When picuture caching was enabled with gfx.webrender.picture-caching;true pref, the score became 20-30.
Priority: -- → P3
Summary: (picture-caching) MotionMark score becomes lower with picuture caching → (picture-caching) MotionMark score becomes lower with picture caching

Potential fix / workaround is https://github.com/servo/webrender/pull/3487 - although I'd still like to see some WR profile graphs of this case, since the difference is very significant and I can't repro here.

Sotaro, is this one also resolved?

Flags: needinfo?(sotaro.ikeda.g)

I retested on P50(Win10), the score was still not good with picture caching.

With picture caching, the score was 22.26. Without picture caching the score was 129.85.

Flags: needinfo?(sotaro.ikeda.g)
Assignee: nobody → gwatson

I retested on laptop(P50 Win10) on https://browserbench.org/MotionMark/, the score became a lot better in general.

With picture caching, the score was 210-230. Without picture caching the score was 250-280.

There is still some score regression, but the regression is not big and I did not saw the regression on another Win 10 PCs. Then It seems OK to close the bug.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.