Closed Bug 1514546 Opened 2 years ago Closed 2 years ago

Unpinning multiple tabs in 64.0 has the wrong text

Categories

(Mozilla Localizations :: en-CA / English (Canada), defect)

defect
Not set
normal

Tracking

(firefox64- wontfix, firefox65 fixed, firefox66 fixed)

RESOLVED FIXED
Tracking Status
firefox64 - wontfix
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: felix.ajs, Assigned: flod)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

Create multiple tabs, and then pin them (together or separately both works).  Then select them and look for the "Unpin" option.

I'm running on Ubuntu 18.04 LTS, in case that's relevant.


Actual results:

The relevant function is just labelled "(P)" in the context menu.  


Expected results:

I expect it should be the same as the single tab text "Unpin".
Which localization are you using ?
I do not see the issue on my original Mozilla.org Firefox 64 en-us on windows and on the Ubuntu Firefox64 de-de (Ubuntu 18.04LTS)
Flags: needinfo?(felix.ajs)
I'm not totally sure where to find that - The closest thing I could find is "Language" in Preferences, where my localization is en-ca.  Let me know if you need me to look somewhere else.
Flags: needinfo?(felix.ajs)
sorry, I forgot to mention that you can open "about:support" in Firefox as URL.
scroll down to the bottom and the used locale should be listed there.
Attached image locales.png
Here's a screenshot of the relevant section.  en-CA seems to be the setting, if I'm interpreting this correctly?
moving to localizations but this could be just a bug in the ubuntu packages.
Component: Untriaged → en-CA / English (Canada)
Product: Firefox → Mozilla Localizations
Version: 64 Branch → unspecified
Thanks!  Is there anything more I need to do at this point?
It's indeed a bug in the en-CA localization
https://pontoon.mozilla.org/en-CA/firefox/browser/chrome/browser/browser.dtd/?search=unpinSelectedTabs.label&string=179970

This string is empty. I just fixed it, it will be in the next Nightly and Beta, but for release we need to wait for the next one.
Assignee: nobody → francesco.lodolo
Interesting, not sure why I left it empty :/
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

[Tracking Requested - why for this release]: A tab context menu label introduced in Firefox 64 is empty in the Canadian English locale. Since the multiple tab organizer is a new feature in the latest release, people may want to try it and be confused to see it blank. It would be nice to get this fixed in 64.0.2.

Flags: needinfo?(jcristau)

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #9)

[Tracking Requested - why for this release]: A tab context menu label introduced in Firefox 64 is empty in the Canadian English locale. Since the multiple tab organizer is a new feature in the latest release, people may want to try it and be confused to see it blank. It would be nice to get this fixed in 64.0.2.

Japanese only had one commit after the previous sign-off, so it was easy and safe to take.

For en-CA, it's a lot more complex (I considered it)

Currently shipping: 74af9d928404
Commit fixing this label: 36afd179171e

Diff: https://l10n.mozilla.org/source/diff/?from=74af9d928404&to=36afd179171e&repo=l10n-central%2Fen-CA

It's definitely a paper-cut, but we only received one bug report as far as I can tell, and I'm not sure it's worth taking the risk, less than 3 weeks from the next release.

wontfix for 64 per comment 10.

Flags: needinfo?(jcristau)
You need to log in before you can comment on or make changes to this bug.